WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] application/x-httpd-php

[Resolved] application/x-httpd-php

  • Hi
    when trying to open the page at http://www.davidkrutpublishing.com/dkp/bookshop/
    in firefox 1.5.0.7 on some machines (some PCs some Macs) firefox says You are trying to open an aplication which is type: application/x-httpd-php

    I suspect it has something to do with the latest firefox update, or something – it only started happening out of the blue a few days ago!?

    I notice that if I take the trailing backslash out of the url it works fine, but other pages can be get to with the trailking backslash, e.g. http://www.davidkrutpublishing.com/dkp/about/

    Very odd me thinks.

    Any help or illumination much appreciated!

    Thanx

    Andre SC

Viewing 14 replies - 1 through 14 (of 14 total)
  • no problems here on 1.5.0.7 from 3 boxes

    could it be a rogue plugin or a corrupt install on the machines?

    was firefox asking you to save the php file rather than open it when you were getting the message?

    yup, firefox asks if it should open it (wanting me to choose an app), or to save it

    I would just reinstall firefox, but it’s happening on a few different machines

    just noticed same error if trying to use the ‘view site’ link from the admin panel. 🙁

    That happens with my Firefox on just about every site I land on … very odd indeed.

    What do get if you save the file, actually? What’s in it?

    And what version of PHP and Apache is your side running?

    If it was asking you to open the file, then it’s more than likely a wrong implementation of PHP on your server, either it’s not configured properly to Apache or Apache cannot see the directory or php files it needs to parse the code.

    BUT

    as i can see it fine here on 3 machines i can’t see that necessarily being the problem, which is wierd as hell.

    Might be worth posting on the Mozilla forums or having a scout through them, incase theres some wierd firewall/browser conflict

    Can you get access to your php.ini file?

    Yup, certainly is weird, also is fine from my personal machines. And the fact that it happened on both PC’s and Macs seems to contradict my initial assumption that it is firewall related. Not sure how to look at the server’s php.ini but will go read up on doing that – thanx. The other very strange aspect is that whatever the issue is it affects only some URLs and not others. Makes me wonder if its not a glitch in the server’s cache (not using the cache plugin on this site)

    Also frustrating that i can’t recreate the problem on my own machines 🙁

    a dump of the servers cache might help here, are they using any mirroring or is it a clustered host?

    Maybe someone could provide a tcpdump?! Would certenly help to understand the problem.

    >>Maybe someone could provide a tcpdump?!

    why would the packet headers help looking for a php issue?!!!!

    Firefox says that the content-type is application/x-httpd-php, if it is, Firefox does right and WordPress or Apache/PHP is at fault, if not it is a Firefox bug. Would be good to know if that is a WordPress/Apache/PHP bug or a firefox bug, wouldn’t it? And maybe the request headers help to reproduce the bug.

    foolswisdom

    @foolswisdom

    Moderator

    This topic was recently discussed on the wp-hackers mailing list in a thread titled “Firefox vs. WP”

    “I’ve seen it happen on perfectly configured when the server is under a lot of load. I have no idea what causes it, if you open up the downloaded file it’s usually blank. I’ve seen it happen on non-WP code so I don’t think it’s something inside of WordPress.”
    http://comox.textdrive.com/pipermail/wp-hackers/2006-September/008787.html

    This seems to agree with my own experience and others on the list.

    Seeing the condition clear when removing the backslash may be a red
    herring if the issue is timing / load related.

    Is it reproducible always on your computer? How often does it occur? Is it only on particular sites?

    Has anyone seen it in IE? Even if not, IE could be working around a
    server side problem… maybe as simply as re-requesting a page. Who
    can say without the source.

    I saw it when I ran out of memory with PHP. Upping it from the default 8MB to 24MB eliminated the issue (for me)

    Oh – and in that case, IE was only showing a “white” /blank page. FF would prompt for the download.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] application/x-httpd-php’ is closed to new replies.
Skip to toolbar