Support » Plugin: WP Broadbean » Applications missing attachments

  • Hi,

    Applications sent via our clients website have recently stopped sending attachments with the application.

    I’ve updated all plugins and WordPress to the latest available version and re-tested but attachments are still not sending.

    I’ve also installed email logging, but still no joy. Emails are logging but no attachments.

    The server is running PHP 5.6.

    Any advice on what might be happening?

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mark Wilkinson

    (@wpmarkuk)

    Hi there, did this start happening after something has changed on your site?

    Hi Mark,

    the theme used on the site was recently changed, it was a minor update to the existing one.

    I tried reverting to the previous theme to perform a test application, but still no joy with it.

    When checking the applications in Broadbean, the name, email address and message are present but the field for attachments are missing.

    I thought it might just be hidden under Screen Options but nothing in there either.

    I’ve checked various other options with our hosting company, upload limits, folder permissions, PHP version, etc, but that didn’t turn up anything either.

    Any thoughts?

    Thanks.

    Plugin Author Mark Wilkinson

    (@wpmarkuk)

    Are you on the latest version of the plugin? The other thing to test is to log the value of $wpbb_attachments here when an application is done to see if the variable contains the attachment.

    https://github.com/highrisedigital/wpbroadbean/blob/master/functions/application-form.php#L357

    Hi Mark,

    WordPress and all plugins were updated when the issues was first reported. I’ve been keeping them up-to-date while working on this but getting no joy from it.

    I’ve been logging emails in the hope that this might turn up something, I just noticed this in json format in the logging screen:

    Application form submission:

    {
        "mail_id": "79",
        "timestamp": "2018-01-24 13:48:23",
        "host": "82.145.42.127",
        "receiver": "client@client.com,\\nmartinm.62805.7513@allstaff.aplitrak.com",
        "subject": "New Job Application Submitted - Applicants name",
        "message": "\t\t\t\n\t\t\t\n\t\t\t\t\n\t\t\t\t\t\n\t\t\t\t\t

    Other emails are in this format:

    {
        "mail_id": "91",
        "timestamp": "2018-01-25 14:25:18",
        "host": "82.145.42.127",
        "receiver": "client@client.com",
        "subject": "CV Upload",
        "message": "From: Dev Test \nSubject: CV Upload from Allstaff.co.uk\n\n--\nThis e-mail was sent from a contact form on Allstaff (http:\/\/allstaff.co.uk)",
        "headers": "From: Dev Test \nX-WPCF7-Content-Type: text\/plain\nReply-To: dev@test.com\n",
        "attachments": "lstaffco\/public_html\/media\/wpcf7_uploads\/1463800735\/Test-doc.docx",
        "error": null,
        "plugin_version": "1.8.3\r"
    }

    I’ve also been seeing this error several times lately in error logs:

    [25-Jan-2018 14:39:36 UTC] PHP Warning: implode(): Invalid arguments passed in /home/allstaffco/public_html/wp-content/themes/all-staff-update/single-wpbb_job.php on line 20

    Is any of this helpful to you? I’ve not logged the value of $wpbb_attachments yet, but I’ll try that next.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Applications missing attachments’ is closed to new replies.