Support » Plugin: WP Job Manager » Application URL not working

  • Resolved ziembatron

    (@ziembatron)


    The Application URL field won’t allow the form Preview to show; it just refreshes the page. If an email address is entered, it works fine. I’ve been using URLs with https:// and http://. The URL doesn’t work for either of the Email address or website URL or Website URLs only settings.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support bindlegirl (a11n)

    (@bindlegirl)

    Hi there!

    I checked your site and this looks like some kind of a conflict. Have you tried disabling other plugins to see if any of them could be causing this?
    I have noticed some 404 and 403 errors in the browser console that look related to Google tag manager. Not sure that is the cause, but I recommend you check them out first.

    Thread Starter ziembatron

    (@ziembatron)

    I’ve tried disabling plugins and I resolved the Google Tag Manager error. The URLs are still not working. Do you have any other suggestions?

    Thanks!

    Plugin Support bindlegirl (a11n)

    (@bindlegirl)

    Have you tried switching the theme to one of WordPress default ones like Twenty-twenty?

    Thread Starter ziembatron

    (@ziembatron)

    This is a live website, so unfortunately that is not an option. What to do now?

    @ziembatron – I believe you can use the Health Check & Troubleshooting plugin, enable “Troubleshooting Mode” and then change your theme to a default one for just you for testing (other site visitors will see your site as normal).

    I also highly recommend creating a staging site to make it easier to troubleshoot issues like these. One way to do this is to create a subdomain, e.g. staging.your-domain.com (your host /its documentation should be able to help with this), then duplicate your site to it using the Duplicator plugin, and finally keep it private by using the Hide My Site plugin (and checking “Discourage search engines from indexing this site” in WordPress admin > Settings > Reading).

    Thread Starter ziembatron

    (@ziembatron)

    hastibe,
    I already have a staging site and the plugin is working there. Do you have any other recommendations for this?
    Thanks.

    @ziembatron – if you’ve been able to isolate the cause to your theme, your best options are reach out to the developer of the theme for a fix (have you posted in their forum?), or hire a developer (i.e. via Codeable) to customize your theme to be compatible with WP Job Manager.

    Thread Starter ziembatron

    (@ziembatron)

    To clarify, the theme, plugins, and settings are identical on each site on different servers. It is not the theme. I’m going to assume that disabling plugins and using a default theme are the only options that you have to offer to troubleshoot your plugin. Thank you for your time.

    @ziembatron – hmm, if the only difference is the server, are you saying that you think the server is causing the issue?

    Plugin Support bindlegirl (a11n)

    (@bindlegirl)

    Since there were no replies here for a while, I’m closing the topic as resolved.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Application URL not working’ is closed to new replies.