Support » Plugin: WooCommerce Stripe Payment Gateway » Apple Pay Setup Not Showing Buttons Despite Domain Verification

  • Resolved AaronFernandes

    (@aaronfernandes)


    Hello

    I have already verified the domain within Stripe for Apple Pay and within WooCommerce I have checked ‘The Payment Request’ buttons under Settings.

    From what I gather the Apple Pay buttons should be showing now? But I don’t see anything else yet.

    Any help appreciated.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support wbrubaker

    (@wbrubaker)

    Howdy 🙂

    I have every reason to believe that this is a theme issue that is causing this problem.

    To disregard anything specific to Apple Pay and domain verification for a moment, we would also expect a “buy now” button when using Chrome and that is not displaying correctly either but all of the HTML code for the button is output.

    If I play around with the CSS while viewing that product page, I can get the button to display – see screencast gif here: http://cld.wthms.co/JXZrk7

    Does this problem persist if you take the following steps:

    1. Temporarily switch to a default theme such as Twenty Seventeen or Storefront https://wordpress.org/themes/storefront/
    2. Deactivate all plugins except for WooCommerce and Stripe

    Kind regards,

    Hi there

    Please take a look at the staging site here : https://sticknpostagin.wpengine.com/product/stick-poke-partner-tattoo-kit/

    The theme has been switched to Storefront and I’ve deactivated all plugins but WooCommerce and the WooCommerce + Stripe plugin but still nothing shows.

    Tried developer tools to set display:block for the payment request buttons but nothing still shows.

    Any help appreciated. Thanks

    Plugin Author royho

    (@royho)

    @aaronfernandes – it is showing. Seen here http://cld.wthms.co/StAauR

    Really? we’ve just checked on multiple computers and mobile devices and it is not displaying for us anywhere nor in the HTML.

    Is there any reason it would only show for you and not for us in both US and Canada?

    Plugin Author royho

    (@royho)

    I believe you need to have an actual Apple Pay Wallet setup with valid payment information.

    Plugin Support wbrubaker

    (@wbrubaker)

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Apple Pay Setup Not Showing Buttons Despite Domain Verification’ is closed to new replies.