Support » Plugin: Stripe For WooCommerce » Apple Pay not displaying

  • Plugin Author mr.clayton

    (@mrclayton)


    In order for Apple Pay to display in your shop, you must test using an iOS device that has a saved payment method in the Apple Wallet.

    Apple Pay will display in Safari private browsing even if the Apple Wallet does not have a saved payment method.

    Here is a link to Stripe’s Apple Pay requirements:

    Stripe Apple Pay requirements

    Kind Regards,

Viewing 6 replies - 1 through 6 (of 6 total)
  • totus88

    (@totus88)

    Hello, I’m receiving this error on Google Chrome from a Macbook, can you please help?

    Uncaught TypeError: Cannot read property ‘elements’ of null
    at ApplePay.wc_stripe.BaseGateway (body-86889b3cc39390cb597a2f5250e21f6f8d39a2e9-1.js:639)
    at new ApplePay (body-86889b3cc39390cb597a2f5250e21f6f8d39a2e9-1.js:643)
    at body-86889b3cc39390cb597a2f5250e21f6f8d39a2e9-1.js:651
    at body-86889b3cc39390cb597a2f5250e21f6f8d39a2e9-1.js:651

    Plugin Author mr.clayton

    (@mrclayton)

    @totus88,

    Please provide your website url. JS errors thrown by the plugin are 99% of the time a result of an integration issue with your site, like a theme or another plugin throwing an error.

    Kind Regards,

    totus88

    (@totus88)

    Hi Mr.clayton here an example: https://digitaldojo.it/prodotto/gift-card-facebook-marketing-business-starter-kit-sensei-elisabetta-macaione/

    The problem arises on a MacBook using Chrome. In fact the Apple Pay button doesn’t appear on Chrome, only on Safari.

    Plugin Author mr.clayton

    (@mrclayton)

    @totus88

    Apple Pay is not supposed to show on chrome. It is not compatible with browsers other than Safari. That is an Apple Pay restriction, not a plugin restriction.

    Kind regards,

    totus88

    (@totus88)

    sure, that’s why I don’t understand why I get this error notification from the browser. 🙁

    Plugin Author mr.clayton

    (@mrclayton)

    @totus88 I recommend you try testing with a default theme like 2020. That will either eliminate your theme as an issue or point to the problem.

    Based on the JS error you pasted, it looks like you’re using some kind of caching plugin. That could also be the cause. Try disabling the cache plugin and testing. Perhaps it has a setting where you can exclude certain scripts.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.