Support » Plugin: WooCommerce Stripe Payment Gateway » Apple Pay failed

  • Resolved hassoun

    (@hassoun)


    Hello,

    API authentication is successful as far as I can tell, tested with a
    real credit card payment, success.

    However, Apple Pay failed. Even though I added
    (apple-developer-merchantid-domain-association) file to the right
    path.

    I contacted Stripe support and they confirmed that everything at my account level is set correctly and that I need to contact the plugin support:

    Thanks for your response. I appreciate your patience towards resolving your inquiry.
    
    I can see that your Apple Pay is activated from your Stripe Dashboard. This is not the only thing that needs to be done to fully utilize this payment method.
    
    Since you're using WooCommerce,  you would need to contact them to integrate Apple Pay as one of your payment methods.
    
    https://docs.woocommerce.com/document/stripe/#apple-pay
    
    I hope you would understand that in terms of WooCommerce integrations, we don't have any specific information to share. There are many third party applications for popular open source projects and Stripe does not build or maintain them. I wish I could be of a bit more help here, but since WooCommerce built their integration with Stripe, they'll be best able to help you with this directly.
    
    Here's a link to WooCommerce support page: https://woocommerce.com/my-account/create-a-ticket
    
    I hope this clears things up. If you have any other concerns or questions, please feel free to reach out to us anytime.
    
    Warmly,

    The button is displayed correctly, but it fails with this error:

    Apple Pay Not Completed
    This website was not able to complete the payment. Please try again later.

    Any advice?

    Regards.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Saravanan S, a11n

    (@simplysaru)

    Hi @hassoun,

    Do you have debug logs enabled for stripe? Are you able to share the logs for an apple pay transaction that failed, so that we can review the same?

    It would also help us if you can share your site status report.
    Could you please send me a copy of your site’s System Status? You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”.

    Once you’ve done that, you can paste the text in https://gist.github.com/ and feel free to change/remove your site URL in the report for privacy reasons.

    Once you do that, you can paste the Gist link here in your reply.

    Thread Starter hassoun

    (@hassoun)

    Hi Saravanan, thank you for your quick response.

    I attached the system report here: https://pastebin.pl/view/98898c18

    The Debug option is enabled already, and I have did several attempts to pay via Apple Pay, and I see a log file generated today, this is all what it contains:

    2021-10-06T14:25:53+00:00 DEBUG 
    ====Stripe Version: 5.6.0====
    ====Start Log====
    account
    ====End Log====

    I don’t know if it’s worth mentioning, (apart from this issue), but the time shown on the drop-down menu does not match the time in the log content, and neither matches the real-time of the attempt. The server and the site’s times are set correctly.

    Anyway, in Stripe’s dashboard, I can see 4 posts requests related to this attempt, all of them returning 200 OK. Should I include the responses here as well?

    Plugin Support 3 Sons Development – a11n

    (@3sonsdevelopment)

    Hi @hassoun,

    Thanks for posting this. Could I get you to open up a ticket for us about this? We’ll likely need to log into the site to see what’s going on.

    https://woocommerce.com/my-account/create-a-ticket/

    Thanks!

    Thread Starter hassoun

    (@hassoun)

    Ticket #4373747 submitted, thanks!

    Plugin Support Chris Moreira – a11n

    (@chrism245)

    Hello @hassoun!

    Thanks for that! — I’m going to mark this as resolved as we are following up with you on that ticket.

    Thread Starter hassoun

    (@hassoun)

    Hello, Chris,

    Neither I have received a responsive vial email nor have I found a way to track a ticket on your website/my dashboard.

    I appreciate it if you would help to find my tickets or track a ticket by number.

    Regards.

    Plugin Support Nicholas E. – a11n

    (@nicholasje)

    Hi @hassoun,

    Sorry to hear that you never received a response! I just reviewed the ticket opened and see that we replied on October 14th. I will resend the response as it seems it never landed in your inbox. Please check your spam folder as well.

    We look forward to hearing from you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.