Support » Plugin: WooCommerce Stripe Payment Gateway » Apple Pay domain verification failed. Please check the log to see the issue.

  • Resolved linux4me2

    (@linux4me2)


    I’m using version 3.1.2 of the Woocommerce Stripe Payment Gateway, and I’m still seeing the “Apple Pay domain verification failed. Please check the log to see the issue.” error message, but now only on the Woocommerce -> Settings pages. There is nothing in the log, and no error messages in my error_logs in the web root or in wp-admin.

    I do see the directory .well-known has been created in my web root, and the apple-developer-merchantid-domain-association file is in there. The site is running with a valid SSL certificate.

    I’ve seen the previous post, which is marked as solved, but this seems like a different issue with the same error message.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author royho

    (@royho)

    When you went to the system status->logs did you actually select the log for Stripe and clicked view?

    There was no log for Stripe when I went to the System Status -> Logs.

    I think I’ve found a workaround, but I need to test it on another site. I logged in to Stripe and went Payments -> Apple Pay and clicked the View Apple’s Terms of Service button and accepted the ToS. After that, I unchecked Apple Pay in Woocommerce -> Settings -> Checkout -> Stripe, saved it, then checked Apple Pay and saved it again. Now I’m no longer getting the error and after I logged out of Stripe and back in, I can see the domain is now added to the Apple Pay page, though it wasn’t until I logged out and back in to Stripe.

    Plugin Author royho

    (@royho)

    Could it be a hiccup?

    I just tried it on another site, and it seems like the sequence of accepting Apple’s terms in Stripe, then unchecking, saving, checking, and saving the Apple Pay option in Woocommerce does the trick. Maybe Stripe is preventing the domain from being validated until the ToS are accepted?

    I’ve got a few more sites I can test it on…

    • This reply was modified 3 years, 8 months ago by linux4me2.
    Plugin Author royho

    (@royho)

    Hmmm interesting. Stripe did not mention this to us during development. I will check with them.

    It looks like what works is to first update the Stripe Gateway, log on to Stripe, go Payments -> Apple Gateway and accept the ToS. No domains will be listed. Back in Woocommerce Settings -> Checkout -> Stripe, uncheck Apple Pay, save, check Apple Pay, save, then go back to Stripe. Click on Transfers or some other category, then go back to Payments -> Apple Pay and if the domain isn’t showing up, click on the ToS button and accept the ToS again. The domain should then appear in the list of validated domains. So far, that process has worked on seven of eight sites. The eighth is a test site still using Stripe in test mode, so that may be why it didn’t work.

    Hi there,

    I have accepted the ToS and have no more error message in WordPress regarding the domain verification. Everything seems to be working fine, however I’m still having only the usual credit cards’logos on the woocommerce payment page, no Apple Pay icon.

    What am I doing wrong?

    Thanks for your support!

    Cheers, Claude

    You have to be viewing the checkout/payment page with an iPhone that has the Wallet enabled and set up. If you’re doing that, and still can’t see the Apple Pay icon, you might try the Storefront theme and deactivate all your plugins except Woocommerce and Stripe to see if it works. You really should start your own thread to get some help, since your issue is different than mine.

    I’m marking this thread as resolved since I have a workaround that fixes the initial problem.

    I found this link. I don’t know how to verify my site. Looks really complicated. Is there a video tutorial for it somewhere, maybe? https://stripe.com/docs/apple-pay/web#verifying-your-domain

    • This reply was modified 3 years, 8 months ago by sillyme727.
    Brendan

    (@brendymullan)

    I had the same issue, linux4me2’s answer above solves the error.

    This workaround solved the issue for me as well. Thanks!

    Worked for me, too, except I didn’t need to accept terms in Stripe. I just unchecked, saved, checked, then saved; error message gone.

    This workaround’s worked for me as well, thanks for reporting it.

    Thanks @linux4me2
    That resolved the issue 100%
    Thank you for sharing this 🙂

    • This reply was modified 3 years, 7 months ago by torkild.

    @linux4me2’s workaround worked for me as well.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Apple Pay domain verification failed. Please check the log to see the issue.’ is closed to new replies.