Support » Plugin: WooCommerce » Apple pay domain verification failed after it was working

  • Resolved xnlzhang

    (@xnlzhang)


    Hi –

    So I setup woocommerce with stripe gateway, and I got the apple pay to work. After about an hour, this message showed up:

    Apple Pay domain verification failed. Please check the log to see the issue. (Logging must be enabled to see recorded logs)

    The log stated:

    2019-12-03T05:25:46+00:00 CRITICAL syntax error, unexpected ‘color’ (T_STRING) in /home/u732275045/domains/lowtechtoyclub.com/public_html/wp-content/plugins/theme-customisations-master/custom/functions.php on line 65

    And the apple pay stopped working. On Stripe, it is showing the domain name under the apple pay settings. Nothing changed between when it was working and when I received the error message.

    Anyone have any ideas?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Tseten D

    (@tibetanitech)

    Hi @xnlzhang,

    Sorry to hear about the trouble there. Do you see any error for Apple Pay when you try to checkout? If you could share a screenshot that shows the problem, that would be helpful. You can upload the screenshot to your media library and share the link with us, or you can use a service like Droplr: https://droplr.com/ or CloudApp: https://www.getcloudapp.com/ to share the image file.

    Can you share which version of the Stripe extension are you running? You can find out by going to Plugins in your Dashboard and looking for Stripe from the list. The version number will be listed below the plugin’s name. Here is a screenshot for reference: https://d.pr/i/KdfxpL.

    I recommend updating it to the latest version. Your log mentioned an error from a plugin called “theme-customisations-master” can you check if disabling the plugin resolves this issue?

    Hey @tibetanitech

    Thanks for taking a look! There were no errors with the Apple Pay on checkout when it was working on the site. (Now that it wont verify, the button doesn’t show up anymore).

    Not sure what screenshot to share, since everything is fine, aside from the fact that the apply pay button doesn’t show up anymore (and the only errors that I got are what I quoted in the first post).

    I’m running Version 4.3.1 of WooCommerce Stripe Gateway.

    And I did disable the theme-customisations plugin, which did not solve the issue. Although I’m not sure if there is a way to force Apple pay to attempt the verification again?

    Plugin Support Tseten D

    (@tibetanitech)

    Thank you for the confirmation that you are using the latest version of Stripe.

    It is possible that the error logs you shared might be the Fatal error logs. Can you please reconfirm if you see any other errors related to Apply Pay in WooCommerce > Status > Logs > Select the latest Stripe log from the list. Here is a screenshot for reference: https://d.pr/i/zYMuQv

    Copy-paste the logs in your response here. Also could you please send me a copy of your site’s System Status? You can find it via WooCommerce > Status.
    Select “Get system report” and then “Copy for support”. Once you’ve done that, you can paste it here.

    Hi,

    This is the latest log from Stripe:

    2019-12-04T16:35:10+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Domain association file updated.
    ====End Log====

    2019-12-04T16:35:10+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Error: Unable to verify domain – missing secret key.
    ====End Log====

    2019-12-04T17:51:59+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Keys are not set correctly.
    ====End Log====

    2019-12-04T17:52:02+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Keys are not set correctly.
    ====End Log====

    2019-12-04T17:52:03+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Keys are not set correctly.
    ====End Log====

    2019-12-04T17:52:03+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Keys are not set correctly.
    ====End Log====

    2019-12-04T17:52:05+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Keys are not set correctly.
    ====End Log====

    2019-12-04T17:53:25+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Keys are not set correctly.
    ====End Log====

    2019-12-04T17:53:25+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Keys are not set correctly.
    ====End Log====

    2019-12-04T18:01:59+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Keys are not set correctly.
    ====End Log====

    2019-12-04T18:02:08+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Keys are not set correctly.
    ====End Log====

    2019-12-04T18:02:14+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Keys are not set correctly.
    ====End Log====

    2019-12-04T18:05:25+00:00 DEBUG
    ====Stripe Version: 4.3.1====
    ====Start Log====
    Error: Unable to verify domain – missing secret key.
    ====End Log====

    And the site system status:

    `
    ### WordPress Environment ###

    WordPress address (URL): https://lowtechtoyclub.com
    Site address (URL): https://lowtechtoyclub.com
    WC Version: 3.8.0
    REST API Version: ✔ 1.0.2
    Log Directory Writable: ✔
    WP Version: 5.3
    WP Multisite: –
    WP Memory Limit: 256 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_US
    External object cache: –

    ### Server Environment ###

    Server Info: LiteSpeed
    PHP Version: 7.2.25
    PHP Post Max Size: 128 MB
    PHP Time Limit: 120
    PHP Max Input Vars: 5000
    cURL Version: 7.62.0
    OpenSSL/1.0.2k

    SUHOSIN Installed: –
    MySQL Version: 5.5.5-10.2.27-MariaDB
    Max Upload Size: 128 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔

    ### Database ###

    WC Database Version: 3.8.0
    WC Database Prefix: wp_
    MaxMind GeoIP Database: ✔
    Total Database Size: 12.13MB
    Database Data Size: 10.34MB
    Database Index Size: 1.79MB
    wp_woocommerce_sessions: Data: 0.08MB + Index: 0.02MB + Engine InnoDB
    wp_woocommerce_api_keys: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_woocommerce_attribute_taxonomies: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_woocommerce_downloadable_product_permissions: Data: 0.02MB + Index: 0.06MB + Engine InnoDB
    wp_woocommerce_order_items: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_woocommerce_order_itemmeta: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_woocommerce_tax_rates: Data: 0.02MB + Index: 0.06MB + Engine InnoDB
    wp_woocommerce_tax_rate_locations: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_woocommerce_shipping_zones: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_woocommerce_shipping_zone_locations: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_woocommerce_shipping_zone_methods: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_woocommerce_payment_tokens: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_woocommerce_payment_tokenmeta: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_woocommerce_log: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_commentmeta: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_comments: Data: 0.09MB + Index: 0.09MB + Engine InnoDB
    wp_links: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_litespeed_img_optm: Data: 0.02MB + Index: 0.09MB + Engine InnoDB
    wp_litespeed_optimizer: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_mailchimp_carts: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_mailchimp_jobs: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_options: Data: 3.25MB + Index: 0.11MB + Engine InnoDB
    wp_postmeta: Data: 4.47MB + Index: 0.22MB + Engine InnoDB
    wp_posts: Data: 1.50MB + Index: 0.16MB + Engine InnoDB
    wp_rank_math_404_logs: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_rank_math_internal_links: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_rank_math_internal_meta: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_rank_math_redirections: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_rank_math_redirections_cache: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_rank_math_sc_analytics: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_shipment_batch_process: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_termmeta: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_terms: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_term_relationships: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_term_taxonomy: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_usermeta: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_users: Data: 0.02MB + Index: 0.05MB + Engine InnoDB
    wp_wc_admin_notes: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_wc_admin_note_actions: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_wc_category_lookup: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_wc_customer_lookup: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_wc_download_log: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_wc_order_coupon_lookup: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_wc_order_product_lookup: Data: 0.02MB + Index: 0.06MB + Engine InnoDB
    wp_wc_order_stats: Data: 0.02MB + Index: 0.05MB + Engine InnoDB
    wp_wc_order_tax_lookup: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_wc_product_meta_lookup: Data: 0.02MB + Index: 0.09MB + Engine InnoDB
    wp_wc_tax_rate_classes: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_wc_webhooks: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_woo_shipment_status_email: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_woo_shippment_provider: Data: 0.05MB + Index: 0.00MB + Engine InnoDB

    ### Security ###

    Secure connection (HTTPS): ✔
    Hide errors from visitors: ✔

    ### Active Plugins (17) ###

    All-in-One WP Migration: by ServMask – 7.10
    Elementor: by Elementor.com – 2.7.5
    Facebook for WooCommerce: by Facebook – 1.9.15 – Not tested with the active version of WooCommerce
    Jetpack by WordPress.com: by Automattic – 7.9.1
    LiteSpeed Cache: by LiteSpeed Technologies – 2.9.9.2
    MC4WP: Mailchimp for WordPress: by ibericode – 4.7.2
    Ocean Extra: by OceanWP – 1.5.19
    Really Simple SSL: by Rogier Lankhorst
    Mark Wolters – 3.2.6

    Rank Math SEO: by Rank Math – 1.0.35.3
    Theme Customisations: by WooThemes – 1.0.0
    Advanced Shipment Tracking for WooCommerce: by zorem – 2.7.3
    Product Gallery Slider for Woocommerce: by codeixer – 2.0.3 – Not tested with the active version of WooCommerce
    WooCommerce Admin: by WooCommerce – 0.22.0
    WooCommerce Stripe Gateway: by WooCommerce – 4.3.1
    WooCommerce Services: by Automattic – 1.22.1
    WooCommerce: by Automattic – 3.8.0 – 3.8.1 is available
    WPForms Lite: by WPForms – 1.5.6.2

    ### Inactive Plugins (3) ###

    Akismet Anti-Spam: by Automattic – 4.1.3
    Hello Dolly: by Matt Mullenweg – 1.7.2
    Mailchimp for WooCommerce: by Mailchimp – 2.3 – Not tested with the active version of WooCommerce

    ### Dropin Plugins (1) ###

    advanced-cache.php: advanced-cache.php

    ### Settings ###

    API Enabled: –
    Force SSL: –
    Currency: USD ($)
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Number of Decimals: 2
    Taxonomies: Product Types: external (external)
    grouped (grouped)
    simple (simple)
    variable (variable)

    Taxonomies: Product Visibility: exclude-from-catalog (exclude-from-catalog)
    exclude-from-search (exclude-from-search)
    featured (featured)
    outofstock (outofstock)
    rated-1 (rated-1)
    rated-2 (rated-2)
    rated-3 (rated-3)
    rated-4 (rated-4)
    rated-5 (rated-5)

    Connected to WooCommerce.com: –

    ### WC Pages ###

    Shop base: #6 – /shop/
    Cart: #7 – /basket/
    Checkout: #8 – /checkout/
    My account: #9 – /my-account/
    Terms and conditions: ❌ Page not set

    ### Theme ###

    Name: OceanWP
    Version: 1.7.3
    Author URL: https://oceanwp.org/about-me/
    Child Theme: ❌ – If you are modifying WooCommerce on a parent theme that you did not build personally we recommend using a child theme. See: How to create a child theme
    WooCommerce Support: ✔

    ### Templates ###

    Overrides: oceanwp/woocommerce/cart/mini-cart.php
    oceanwp/woocommerce/content-single-product.php
    oceanwp/woocommerce/loop/loop-start.php
    oceanwp/woocommerce/single-product/title.php

    ### Action Scheduler ###

    Complete: 236
    Oldest: 2019-11-18 14:31:58 -0500
    Newest: 2019-12-06 18:35:09 -0500

    Pending: 1
    Oldest: 2019-12-06 19:35:09 -0500
    Newest: 2019-12-06 19:35:09 -0500

    Canceled: 1
    Oldest: 2019-12-03 21:19:56 -0500
    Newest: 2019-12-03 21:19:56 -0500

    In-progress: 0
    Oldest: –
    Newest: –

    Failed: 0
    Oldest: –
    Newest: –

    `

    Plugin Support Tseten D

    (@tibetanitech)

    Hi @xnlzhang!

    Thank you for sharing the error logs and your Status Report.

    Keys are not set correctly.

    It appears that the keys might be pasted incorrectly. I’d suggest pasting in the keys again from WooCommerce > Settings > Payments > Stripe.

    Here is a screenshot for reference: https://d.pr/i/0OrR7i

    You can get the Test and Live keys from Stripe here,

    https://dashboard.stripe.com/account/apikeys

    Once you do that please try another test payment.

    Hi,

    So once I replaced the keys, the apple pay domain verification failed warning went away. However, the apply pay button still isn’t showing up on Safari on my iPhone.

    Plugin Support Tseten D

    (@tibetanitech)

    Hi there!

    I’m glad to know that the Apple Pay domain verification failed warning went away after replacing the API keys.

    I understand that you are having another issue with it as the Apple Pay button is not showing in your iPhone Safari browser.

    Can you check if your browser is up to date? You’ll find a list of the latest browsers at Browse Happy.
    http://browsehappy.com/

    I would also try clearing your browser cache to see if that helps solve the issue.
    https://en.support.wordpress.com/browser-issues/#clearing-your-browser-cache

    Here is some more information about browser issues:
    https://en.support.wordpress.com/browser-issues/

    Please let me know if any of those suggestions work to solve the issue. If it doesn’t, this is likely caused by a conflict with your theme or with another plugin.

    The best way to determine if the issue is being caused by a theme and/or plugin is to temporarily switch your theme to Storefront (https://woocommerce.com/storefront/?aff=10486&cid=1131038) and disable all plugins except for WooCommerceand Stripe.

    Finally, test to see if the issue is resolved by doing a test purchase to check if Apple Pay is working.

    To figure out which plugin is causing the problem, continue to the next step – reactivate your other plugins one by one, testing after each until you find the one causing conflict.

    Here’s a more extensive explanation in our docs: https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    —–

    Tools to help you troubleshoot:

    Meks Quick Plugin Disabler is a plugin you can install which will remember what plugins you currently have active so it’s easy to switch them back on. Link: https://wordpress.org/plugins/meks-quick-plugin-disabler/

    You can clone your site to a staging environment and perform tests without modifying your live site or impacting customers. Many hosts provide staging facilities, so it’s worth checking in with them. It’s also possible to do it using the free WP Staging plugin. Link: https://wordpress.org/plugins/wp-staging/

    Let us know how it goes! 🙂

    Hi –

    So after testing the plugins and themes, nothing worked. But, I tried this below, and it worked!

    From @jownas:

    Hello,

    I had the same problem.
    Try to add the domain for apple payments again in Stripe dashboard by removing the domain you have added. Dont add the domain again before my other steps is done.
    After that go to Stripe settings in Wooocommerce. Uncheck apple pay and save. After that accept the tos on stripe dashboard and activate the domain you want to use with apple pay. Once that is done activate apple pay in woocommerce stripe settings once again and click save.
    Worked for me.

    Plugin Support Tseten D

    (@tibetanitech)

    I’m glad you are able to find a solution with the help of @jownas. And thank you for sharing the solution with us. 🙂

    I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.