Support » Plugin: Mailchimp for WordPress » Appended text

  • Resolved tomazsusnik

    (@tomazsusnik)


    Hello all!

    I am using the latest version of mc4wp (4.5.1), the free version.
    Below my signup form the text “Leave this field empty if you’re human:” is showing. Can I hide this text?

    Thanks in advance!

    Tomaz

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Lap

    (@lapzor)

    Our plugin uses inline CSS code to hide that field, and something seems to be stripping that inline CSS from the code on your site. Maybe some sort of caching/optimisation plugin you are using? Do you have any plugin like that? Or a security plugin maybe?

    tomazsusnik

    (@tomazsusnik)

    I tried temporarily disabling all plugins (apart from mc4wp), but to no avail. Maybe there is something in my CSS overriding the inline CSS? Not sure what to search for …

    • This reply was modified 3 months ago by  tomazsusnik.
    Plugin Contributor Lap

    (@lapzor)

    It could be some “feature” build into your theme. You could test with another theme?
    Before you do this make sure to have a good backup because some themes may lose some of their settings as soon as you switch theme, even if you switch back right after.

    Adding the following CSS code should fix it:

    .mc4wp-form label { display: none; }
    .mc4wp-form .mc4wp-form-fields label { display: block; }

    Hope that helps. If you have any questions, please let us know!

    tomazsusnik

    (@tomazsusnik)

    Unfortunately the above CSS code didn’t help. As it was obvious there was something in my CSS causing the problem I restructured the part containing the mc4wp form. Instead of using the [mc4wp_form] shortcode inside a post I am now using the mc4wp_show_form() function directly from php. That resolved my problem.

    Thanks for the support!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.