Support » Plugins and Hacks » Qtranslate Slug » [Resolved] Second language url/slug 404 error!

[Resolved] Second language url/slug 404 error!

  • Hi Carlos,

    a) I am getting an 404 error pages on Blog Posts & Few Pages for 2nd Language.
    b) For 1st Language it works fine.
    c) 70% of pages are properly translating the language only the blog post & PR pages are showing 404 error.
    d) I have read FAQ & support links related to the respective issue but can’t help it out.

    Can you please provide some suggestions


Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Carlos


    I need more information, can you tell me witch versions are and put some example please?

    Hello, i have the same problem. And thank you Carlos for this free plugin. I tried to reach you but i couldnt find any contact information execpt twitter.

    On this website :


    Everything works great exept the permalink. I think i spent 5 hours to solve this problem but nothing worked. I didnt understand what is wrong. When i change permalink as default all the pages are working but when i use /%postname%/ all pages give 404 not found. Could you help me on this?

    The link i see on the page is the same link with the 404 not found page. Its look impossible, there is a link izobay.com/tr/hakkimizda/ i can see on hakkimizda page. But when i click it gave 404 page.

    I use the last version of wordpress and now i tried developer version of qtranslate. Problem still same.

    Also i am using qTranslate slug with Widget.

    Similar problem with me.
    It works fine with qTranslate, and the error appears when using mqTranslate.
    URLs like http://<website>/<lang>/category/<any-category-slug>/ only work in the main language. For example <lang>=en and <any-category-slug>=games.
    When using another language (for example <lang>=es and <any-category-slug>=juegos) it does not reach the page, I get 404 errors or “no elements in category”.

    Sorry, I said it worked with qtranslate but no. It does not work either with qtranslate or mqtranslate.

    When I check the information in a category I get this:
    public ‘term_id’ => &string ‘4’ (length=1)
    public ‘name’ => &string ‘Citrus’ (length=6)
    public ‘slug’ => &string ‘citrico’ (length=7)
    public ‘term_group’ => string ‘0’ (length=1)
    public ‘term_taxonomy_id’ => string ‘4’ (length=1)
    public ‘taxonomy’ => string ‘category’ (length=8)
    public ‘description’ => &string ” (length=0)
    public ‘parent’ => &string ‘3’ (length=1)
    public ‘count’ => &string ‘1’ (length=1)
    public ‘cat_ID’ => &string ‘4’ (length=1)
    public ‘category_count’ => &string ‘1’ (length=1)
    public ‘category_description’ => &string ” (length=0)
    public ‘cat_name’ => &string ‘Citrus’ (length=6)
    public ‘category_nicename’ => &string ‘citrico’ (length=7)
    public ‘category_parent’ => &string ‘3’ (length=1)

    The category name and slug are always presented in the same language and so I cannot search by another language.

    Plugin Author Pedro Carvalho


    Hello everyone, its been 5 months, do you still have any problems after our releases?

    thanks for using this plugin!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Second language url/slug 404 error!’ is closed to new replies.
Skip to toolbar