Support » Plugin: Insert Pages » App v3.4.7 not compatible with WP v4.9.6

  • Resolved imageintegral

    (@imageintegral)


    Hi guys,
    After updating your plugin today, I got the following error message…

    Fatal error: Uncaught Error: Call to undefined function register_block_type() in /var/sites/c/croydonemencap2.org.uk/public_html/wp-content/plugins/insert-pages/insert-pages.php:91 Stack trace: #0/var/sites/c/croydonemencap2.org.uk/public_html/wp-includes/class-wp-hook.php(286): InsertPagesPlugin->insert_pages_unit(“) #1 /var/sites/…………. etc (taken from a screen-shot)

    I had to recover by restoring the site to before before the update. Is this any help?
    Thanks
    Phil

Viewing 6 replies - 1 through 6 (of 6 total)
  • nuithon

    (@nuithon)

    Same problem here! And the tricky issue is moreover that the plugin updates automatically before I am able to access the admin panel of the website on which I am using it, thus preventing me to disable the update – and thus the problem is back…

    nuithon

    (@nuithon)

    Although I was not too enthusiastic, I updated my website from WP 4.9.10 to WP 5.2.4 (from the control panel of the hosting company), and it fixed the issue.

    Still, I have some other sites on which I do not want to use Gutenberg for the time being, and I would be upset if something like that happened to them. I would be good to have a fix, especially since the plugin is supposed to work for earlier WP versions.

    Very useful plugin, by the way: thank you for having developed it and for maintaining it!

    Mark Krieger

    (@markcanada)

    Same issue on a site with 4.9.12

    Robert Doyle

    (@robert-doyle)

    After updating to new version site displays a blank white page. Also using WP 4.9.12.

    Thankfully I had a backup.

    Looking forward to learning this great plugin is back up and running well.

    Plugin Author Paul Ryan

    (@figureone)

    We unintentionally released Gutenberg support in this plugin; it should have been a minor version bump instead of a patch version bump. We’ll release another update shortly to support older WordPress versions without Gutenberg.

    FYI you can run latest WordPress and *not* use Gutenberg; just install the Classic Editor plugin.

    Plugin Author Paul Ryan

    (@figureone)

    Version 3.5.0 is now released with a fix for older WordPress versions.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘App v3.4.7 not compatible with WP v4.9.6’ is closed to new replies.