Support » Fixing WordPress » Apostrophe == Question mark?

  • After upgrading to 1.2 I noticed that most, if not all of my apostrophes have become question marks, most annoying and I dont have any idea on how to get them back. Obviously I cannot convert all question marks to apostrophes by script or something because that would change everything. So far I have tried chaning the encoding to ascii and I have tried searching the posts here but the only thing I found was about cutting and pasting sometimes causes that. Any ideas from anyone?

Viewing 8 replies - 1 through 8 (of 8 total)
  • its a textile issue i think… wp converts ‘ to ’

    So anyone have any ideas on how to fix this? Do I have to edit code somewhere? I shouldnt have a problem with that but which php file to edit?

    Moderator Matt Mullenweg

    (@matt)

    Troublemaker

    You were probably using a different character set before. Switch UTF-8 in your options to whatever you were using before.

    or, convert your db to utf-8:
    1) backup
    2) download a db dump
    3) open the dump with a text editor, using the old charset
    4) save the dump with a new filename and having selected UTF-8 as the charset
    5) upload the dump.
    If it doesn’t work and everything is unreadable, restore the old db with the original backup.

    That makes perfect sense and should work! Thanks sooo much for the help, I will post back and let everyone know results when I get a chance to do this.

    I can confirm this behavior. However, this is my problem. I had text in microsoft word. I copied and pasted it into notepad (to remove formatting). i then copied and pasted that into my WordPress. Later, i notice the ‘ have become ? and clicking the RSS under Meta no longer works. I went into wordpress, edited the few posts this happened on to change ? to ‘ and it worked fine. Luckily i did not have many posts to do this to. using wordpress 1.2 mingus. no hacks (modified index.php and css though)

    Ok guys, I got it sorted! Heres how I did it:
    I do belive this was an issue with cutting and pasting from MSWord or something because I often do that very thing. I can tell the posts I made via the browser and they look alright but about half of them had problems.
    MAKE A BACKUP JUST IN CASE
    If you have phpmyadmin click on the wp_posts table and then click on the export tab, check Add Drop Table, check Save As File, then hit go. It will ask you to download the entire post archive in sql format. Open it in editplus (my favorite!) or something similar that can save in different char formats. Save as UTF-8 just like it says in the wordpress recommended options.
    MAKE ANOTHER BACKUP JUST IN CASE
    Click on the sql tab at the top and click the browse button, browse to wherever you saved the utf-8 encoded sql file and hit go.
    this should delete your old wp_posts table and import all the posts back in just as they were before, cept not screwed up.
    I had to remove the top comments from the exported SQL file because of some weird reason and you may or may not have to.
    SOoooo, I hope this helps whoever comes across the same problem that I did. Thanks for all the excellent suggestions and tips everyone. Happy posting.

    This sort of worked for me. For some apostrophe’s and quotation marks, it fixed them. For others, it just replaced them with a different weird mark.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Apostrophe == Question mark?’ is closed to new replies.