WordPress.org

Support

Support » Plugins and Hacks » Event Calendar » Apostrophe in text field changes to \'

Apostrophe in text field changes to \'

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yes I have the same problem – every apostrophe somehow gets a \ when I save the event.

    There is documentation on this : http://php.net/manual/en/security.magicquotes.disabling.php

    Damn – we had the Calendar/Events on a client’s WP subsite pretty well sorted; after churning through all the other plugins we found AEC 1.02. Nice.

    The apostrophe issue remained but they just avoided this punctuation.
    Turning off Magic Quotes was tested but this prevented file uploads on their main CMS site, so was reinstated.

    Trustingly, I updated to AEC 1.04 assuming (!) that the apostrophe issue would be solved. No such luck – and the annoying message remained at the top of the plugins page so deleted and reverted to 1.02.

    Hello 🙁 Now of course their calendar entries are gone, as the plugin or WP has no way to retain these in the DB while deleting the plugin files.
    Urggh – a dive into the database to restore – but this has not gone flawlessly either.

    A great plugin – but how about making it a paid one and using the income to make it truly head and shoulders above the rest?

    Other posts on this topic have said to turn off magic quotes in the php.ini file with the following:

    magic_quotes_gpc = Off

    or put this in functions.php

    <?php
    if ( get_magic_quotes_gpc() ) {
    $_POST = array_map( ‘stripslashes_deep’, $_POST );
    $_GET = array_map( ‘stripslashes_deep’, $_GET );
    $_COOKIE = array_map( ‘stripslashes_deep’, $_COOKIE );
    $_REQUEST = array_map( ‘stripslashes_deep’, $_REQUEST );
    }
    ?>

    But I’m not any kind of programmer, so I have no idea how to accomplish this.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Apostrophe in text field changes to \'’ is closed to new replies.
Skip to toolbar