Support » Plugin: Publish To Apple News » APO / cURL timeout error

  • Resolved pappaclart

    (@pappaclart)


    I keep getting the below error.

    have been though google to try and find what is causing the issue and also have spoken with my host. (I have a dedicated server)

    The error shows less often now but on some articles when trying to publish, no matter how many time the error will show.

    Some of the things tried.

    `Temporarily Disable WordPress Firewall.
    Deactivate All WordPress Plugins.
    Fix SSL Insecure Content Issues.
    Changing the global timeout via php.ini.
    Checking ciphers (SSL) TLS 1.1, 1.2, 1.3 enabled.
    Tried to add an additional resolver under /etc/resolve.conf
    Curl version.`

    There has been an error with the Apple News API: There has been an error with your request: cURL error 28: Operation timed out after 30000 milliseconds with 0 bytes received

    If you need assistance, please reach out for support on

    Any ideas would be greatly appreciated.

    Thanks

    Regards

    Ryan

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Kevin Fodness

    (@kevinfodness)

    Do you have the “Use Remote Images” setting turned on? This error could be caused by trying to send large images to Apple along with the article and the request timing out. Remote images is the preferred method of including images in your article, and is turned on by default on new installations of the plugin.

    Thread Starter pappaclart

    (@pappaclart)

    Hello Kevin thanks for the reply it is much appreciated.

    That setting is currently off.

    Our images are not large, generally 200-400kb for originals. The thumbnails smaller still. We do have a lot of images in some of our content but I’d imagine it should not be a problem.

    If you think it is an image problem could it be that our images are served as WebP? using this plugin? https://wordpress.org/plugins/webp-converter-for-media/

    Edit – disabled Plugin and no difference.

    This is a recent article that shows the API error. Do you think that there are too many images? https://www.mcnews.com.au/2022-yamaha-wr250f-specifications/

    Thanks

    Regards

    Ryan

    • This reply was modified 3 months, 3 weeks ago by pappaclart.
    Plugin Author Kevin Fodness

    (@kevinfodness)

    It’s entirely possible that the quantity of images is contributing to this problem. I would strongly recommend turning on the remote images setting (not just for this issue, but because it is the preferred way to send images to Apple) and testing.

    Thread Starter pappaclart

    (@pappaclart)

    Thanks that sorted in the end 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.