Support » Plugin: Advanced Post List » APL PHP_Function Shortcode and Gantry

  • Resolved signale

    (@signale)


    Just to enrich the forum this time.
    Now, I’ve successfully displayed posts list on one of the standard sites(very custom layout, so I used PHP_Function Shortcode). But when I tried to transfer the solution into the Gantry based site, it refused to work.
    The work around:
    – Gantry got Development mode, so to see the actual error, it needs to be turned on.
    – Then the message displays the issue – it expects 2 params (despite the fact that on other site didn’t)
    – After giving the first param=post, it loads

    So, be aware 🙂

    • This topic was modified 1 year ago by  signale.
Viewing 1 replies (of 1 total)
  • Plugin Author Advanced Post List

    (@advancedpostlist)

    Yea, the post param is required as the first param, and shortcode attributes as the 2nd param. It often gets missed, and have thought about improving the concept (without introducing breaking changes).

    The error probably displayed because the live site may be running PHP 7.2+; which may explain why one site was different from the other.

Viewing 1 replies (of 1 total)
  • The topic ‘APL PHP_Function Shortcode and Gantry’ is closed to new replies.