Support » Plugin: WP Geo » API v3 not working

  • Hi there,

    I’ve just updated your plugin and I’ve tried to setup a APV v3 key but when I post it it’s not working. I’ve tried both server and browser IPs.

    If I use the server API I get this error:

    Google has disabled use of the Maps API for this application. The provided key is not a valid Google API Key, or it is not authorized for the Google Maps Javascript API v3 on this site. If you are the owner of this application, you can learn about obtaining a valid key here: https://developers.google.com/maps/documentation/javascript/tutorial#api_key

    If I use the browser API I get this one:

    Google has disabled use of the Maps API for this application. See the Terms of Service for more information: http://www.google.com/intl/en_US/help/terms_maps.html.

    The weird thing is that I didn’t change any settings other than to update my API account to use v3, and when I load the page the map actually loads, with the points on it, for a split second, before the error pops up. After that the message is blank.

    http://wordpress.org/plugins/wp-geo/

Viewing 1 replies (of 1 total)
  • Plugin Author Ben Huson

    (@husobj)

    You need to create a new Browser Key.

    I usually then set allowed referrers just for my site. e.g.:

    www.example.com/*
    example.com/*
Viewing 1 replies (of 1 total)
  • The topic ‘API v3 not working’ is closed to new replies.