Support » Plugins and Hacks » Recent Facebook Posts » [Resolved] API status: Not Connected

[Resolved] API status: Not Connected

  • Hello,

    Just installed the plug-in, but am having trouble setting it up. I’ve followed all the instructions perfectly, properly entered my APP ID and App Secret (and reset / reentered a couple times just to be safe), but no matter what I do I can’t get the API to connect.

    “Facebook API status: Not Connected

    The plug-in also thinks I’m not logged into Facebook, which I definitely am. When I click the ‘log in’ link in this error message…

    “Error: The plugin is not connected to Facebook. Please log in.

    … nothing happens.

    I’ve been through the instructions several times, have read through posts from people with similar problems, and I just can’t come up with an answer. Any help would be appreciated.


    – Brad



Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Danny van Kooten


    Hi Brad,

    The “log in” in the error message doesn’t mean you’re not logged in into Facebook but just means that the plugin is not connected. I’ve changed this message in future versions of the plugin so it’s more clear.

    If you click the “log in” link or the “get new access token” button, nothing happens? The plugin does not redirect to Facebook? No error messages show up?



    Hi Danny,

    Thanks for the response, much appreciated.

    When I click the ‘log in’ link, the page appears to reload, but that’s it. The “Error: The plugin is not connected to Facebook. Please log in.” in the pink-shaded box is still present, and the “Facebook API status: Not Connected” remains. No other error messages appear.

    Same thing happens when I click the “Get Access Token” button. Page refreshes, same messages as above.

    – Brad

    Plugin Author Danny van Kooten


    Hi Brad,

    Hmm. Strange, no error messages..

    A few questions just to be sure and so I can track the issue and fix it.

    After clicking the “log in / connect” link or the “get access token” button, does the URL of your browser window change to “admin.php?page=rfb-settings&logged_in“. Maybe there are more parameters, but could you check to see if logged_in is present in the URL?

    On developers.facebook.com at your application settings…
    – …did you select “Website with Facebook login”?
    – …did you fill in your WordPress URL in the Site URL field?
    – …did you fill in your WordPress domain in the App Domains field (optional but recommended)

    Also, could you go to Advanced App settings (still on developers.facebook.com) and tell me the settings for the following 3 checkboxes.

    Client OAuth Login, Embedded browser OAuth Login and Require AppSecret Proof for Server API calls.

    Thanks! Danny.

    Hi Danny,

    – Yes, the URL does include “logged_in”
    – “Website with Facebook login” was/is selected, with Site URL populated (includes http://, yes?), and I just filled in the App Domain field to be safe (without http://).

    On Advanced tab:
    Client OAuth Login is enabled, Embedded browser OAuth login is disabled, Require AppSecret Proof for Server API calls is disabled. I haven’t touched these, so those are defaults. Should I change any of them?

    thanks again,

    – Brad

    Plugin Author Danny van Kooten


    Hi Brad,

    Yep, all your settings seem to be right. I have the same default advanced settings but I heard of one of my plugin users who had what looked like the same issue that requiring the AppSecret proof fixed it for him.

    You could try that or try re-downloading the latest version of Recent Facebook Posts here. I’ve updated the Facebook API class but didn’t increase the version number because I do not want to push out another update too soon.

    The update addresses parts of the authorization process with Facebook so it might help.

    Thanks for your help. I’m really willing to track this issue down to the cause but can’t seem to be able to replicate it. The fact that there’s no error message doesn’t help either.


    Hey Danny,

    You’ll be happy to know that updating to the just-released new version fixed my problem instantly. All I did was click the new “connect” link and I had my first-ever successful connection to Facebook.

    Thanks very much, I appreciate it. A donation is comin’ your way…

    – Brad

    Hi Danny,

    I’m afraid I’m seeing the same issue as Brad was. Fresh install of WP 3.6 with v 1.4 of your plugin and I’m getting a whole lot of nothing when I click “Connect”. Settings for the application at Facebook are all consistent with Brad’s including the domain settings and oAuth settings. Also tried multiple browsers, clearing caches, forcing the “Connect” routine to go through a login process rather than rely on my existing access token, etc. but just wind up back at the page with no connection. Again, I’m afraid I don’t have error messages for you, etc. but wanted to flag that there still might be an issue there. I wondered if it was related to the wackiness of FB having mistakenly disabled a whack of apps the other day, though that wouldn’t explain why Brad got up and running with a fresh 1.4 install…


    Plugin Author Danny van Kooten


    Hi Reid,

    Thanks for the extensive description. It sounds like you know a thing or two about how things work so that’s really helpful in tracking the bug for me.

    The only thing I can think of right now is that it might be a server issue or an incompatibility with some other plugin. The authorization is mostly handled by Facebook’s API class though, so there’s not much that could go wrong in “my part” of the code.

    I’ll have another close look and do some extensive testing. I’ll let you know if I need to know anything from you, thanks again!

    Having simular issues as stated above. Follow the steps above and still cannot this to connect.

    Hi Danny
    In my wordpress site I want to disply all public posts of facebook posted by me.
    Can you help me regrading this.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] API status: Not Connected’ is closed to new replies.
Skip to toolbar