Support » Plugin: BBQ Firewall » API requests return 403

  • Hi there,

    First of all: We love your plugin and it is really super-easy to use. However, we experience an issue with the latest version unfortunately: The new version causes API requests coming out of Python to be blocked and the API to return a 403 error.

    The same requests over the browser still work fine though.

    Is this something we can fix somehow or do we have any possibility to change a setting maybe?

    If you need further information, please do not hesitate to let me know.

    Thank you!

    Best regards,

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeff Starr


    Hi Christopher,

    Thanks for reporting. I will remove python from the user agent rules for the next plugin update. In the meantime if you want to implement the change now, follow these steps:

    1. Open block-bad-queries.php
    2. On line 51 find the array of user agents
    3. Locate python in the array and remove it

    Specifically, remove the following characters exactly:


    Then save changes and test that it’s working correctly.

    Thread Starter Christopher Mailänder


    Hi Jeff,

    Thank you very much for the incredibly quick answer.

    I will try with my colleague.

    Plugin Author Jeff Starr


    Hey Christopher, just to follow up. The python pattern is removed in the latest version of BBQ (20201123). So the above mentioned steps no longer are necessary. Thanks again for your feedback.

    @swissspaceboy BBQ blocks requests longer than 2000 characters. That example URL is over 2200 characters (!). In any case, the latest version of the plugin can be customized using the BBQ Customize plugin. It enables you to disable the long-request check so that BBQ never will block crazy long URLs (like the example you share above). Thank you very much for reporting.

    Thread Starter Christopher Mailänder


    Thanks again. I really aprpeciate it!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘API requests return 403’ is closed to new replies.