Support » Plugin: Mailchimp for WooCommerce » API Request Error – cURL error 28

  • Resolved edinaldo9

    (@edinaldo9)


    Hello. I’m developing a website where I need to integrate with MailChimp for email marketing purposes. However when I install the plugin and insert the generated key into the administrative panel of the site, I get the following error:

    Mailchimp says: API Request Error - cURL error 28: Operation timed out after 30001 milliseconds with 0 out of -1 bytes received

    WordPress Version: 5.0.3
    MailChimp for WooCommerce Version: 2.1.13
    CUrl Version: 7.29.0
    PHP version: 7.0

    Has anyone gone through this can you give me a light? Thanks in advance!

Viewing 13 replies - 1 through 13 (of 13 total)
  • edinaldo9

    (@edinaldo9)

    actually i think the problem is probably the cURL version in my service host. I have tried to connect MailChimp to another WordPress sites in differents hosts, even in localhost, and it worked.

    Trying to update the cURL to the latest version might work.

    Plugin Author ryanhungate

    (@ryanhungate)

    thanks for helping out… it’s very nice to see that here.

    We’re actively trying to resolve all plugin discrepancies – so when you provide technical details like this it helps tremendously. I can assure everyone that it will be looked at in a release cycle coming up.

    We are currently working on 2.1.14 of the plugin and we’re thinking that this just might resolve some of the plugin install hangups. Stay tuned for that soon 🙂

    edinaldo9

    (@edinaldo9)

    @ryanhungate alright, we’re waiting for further informations.

    Plugin Author ryanhungate

    (@ryanhungate)

    @edinaldo9 we just updated the plugin to 2.1.14 yesterday – so please update when you get a chance and let us know if you’re still experiencing issues.

    On a side note, we’re starting to see a connection between the problem you’re experiencing and other cron related tasks being handled by WPCron during the validation requests being made by the plugin on setup. Here are a couple of options to mitigate this issue – which we also recommend for better user experience ( less browser load times on cron events ).

    1. Set up a TRUE cron job on your server that runs every minute to ping the wp-cron – allowing these tasks to be performed outside of a visitor’s browsing experience:

    * * * * * wget http://yoursite.com/wp-cron.php

    2. If you don’t have access to set a TRUE cron job, you may also use an “uptime” service that PING’s your site the same way. There are many uptime services available to use, so we’re not going to recommend one – but a quick search could show you a few options. As long as you can specify the URL to be pinged, it’s basically the same thing.

    By doing this – these background tasks that need to be run will be picked up by these cron processes vs. YOUR process that’s seems to be blocking the actual Mailchimp task from being complete.

    We do realize this is a long winded answer – but it’s one of many optimizations worth doing.

    Ive updated the plugin and still have the same issue @ryanhungate

    The info provided above is far too technical for me. Any other ideas?

    @ryanhungate, I am now using the latest version of the plugin yet I experience the same problem. The initial connection after I supply an API key fails with the ‘cURL error 28’.

    Regarding the cron jobs, could you please post step-by-step instructions on how to achieve this?

    I am running the plugin successfully on other sites that are running the same version of WC, WP and are hosted in an identical environment. The site that fails, however, has around 500 orders to sync whereas the other sites have only a few. Could this be a matter of increasing the timeout value or smth?

    I also have the latest version of the MailChimp Woocommerce plugin running on Godaddy. Using WPcrontrol, I am unable to set up a chron job (error code 49). I use ManageWP to monitor uptime. But that does not seem to fix the Curl error with your plugin. Any further advice?

    Zlatte

    (@zlatte)

    Hello, I also get the same problem: cURL error 28. Talked to my host and they say no problems on the server side. Increased memory to 512MB and still not conecting. I believe the Mailchimp developers have to address this issue more seriously because it seems to be a widespread problem. Can you tell me how to fix this or when do you think it will be fixed?

    Only version 2.1.11 works fine, now. I get the same error with all proceeding versions including the latest 2.1.15.

    Hopefully there is a fix, soon.

    tdechangy

    (@tdechangy)

    Hey, why is this thread set as resolved while so many are still experiencing this issue ?

    Am am seriously trying to sync my products for the first time and after a lot of search and trials I was only able to connect the API with version 2.1.11 to.

    Please re-open this ticket until the solution is expressly recognised by users to be solved. AND/OR link to any other thread that you would find more relevant.

    you can see some here :
    https://wordpress.org/support/topic/mailchimp-says-api-request-error-curl-error-28-operation-timed-out/
    https://github.com/mailchimp/mc-woocommerce/issues/325

    All threads are telling that version over 2.1.11 are not working or unstable.

    Waiting for the best link to see your implication on solving this important issue.
    Regards.

    Andrius M.

    (@italpasta)

    I’d like to 2nd @tdechangy. Why is this thread inactive and MC is not working to resolve this issue? This still prevents me from using MailChimp and I’ll eventually be forced to look for other solutions. None of the fixes outlined here solved the issue and I’m still unable to do the initial sync with MC.

    UPDATE: I was finally able to sync using v 2.1.11. None of the higher versions worked.

    • This reply was modified 5 months ago by  Andrius M..
    Andrius M.

    (@italpasta)

    Another update. I changed the store name in the plugin settings, hit resync and then got the following error:

    Mailchimp says: API Request Error – on 1474 in /wp-content/plugins/mailchimp-for-woocommerce/includes/api/class-mailchimp-api.php

    Mailchimp says: You must enter in a valid API key.

    The API key did not change and is valid (the initial sync succeeded).

    Plugin version 2.1.11

    Life is too short. This problem needs fixing or I will be looking for other email services. I’ve already wasted too much time on this.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.