Support » Plugin: Mailchimp for WooCommerce » API Request Error – cURL error 28: Operation timed out after 5001 milliseconds

  • Resolved kepy

    (@kepy)


    Hello.

    I’m developing a website where I need to integrate with MailChimp for email marketing purposes.

    I have installed the following plugin and WordPress:
    – WordPress version 5.1
    – WooCommerce version 3.5.5
    – Mailchimp for WooCommerce version 2.1.14
    – PHP version 7.3

    However, when I try to insert the generated API key into the administrative panel of the site, I get the following error:

    Mailchimp says: API Request Error - cURL error 28: Operation timed out after 5001 milliseconds with 0 bytes received

    I try so many solutions but can’t fix this error. So please look into this error and help me to fix these issues.

    Thanks,
    Ketan.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author ryanhungate

    (@ryanhungate)

    @kepy thanks for the info. Let’s look at a few things:

    1. Do you know if your host has blocked access to the admin-ajax.php file?

    2. Do you have a server that’s making use of multiple IP addresses? If so – you may need to configure your site to use the specific IP address of your domain for CURL requests. You can find documentation on that [here](https://github.com/mailchimp/mc-woocommerce/issues/337#issuecomment-466418981).

    3.Do you have any WPCron jobs being scheduled by chance? If so – please reference [this post](https://wordpress.org/support/topic/api-request-error-curl-error-28/#post-11281509) where we describe how to set up a scheduler that will not get in the way of the way our plugin handles ‘jobs’ in the background processes.

    Let’s see how this works first – then we can continue troubleshooting.

    Sorry for using this topic too. I have the same problem.

    I hosted my website at Strato and they said that they do no block any things and i have no WPCron jobs.

    BUT the website is on a shared server. (the wordpress hosting package)

    If i do a curl request in the console it strangely works.

    • This reply was modified 7 months, 2 weeks ago by  paifgx.
    • This reply was modified 7 months, 2 weeks ago by  paifgx.
    • This reply was modified 7 months, 2 weeks ago by  paifgx.

    Hi,

    as I’ve noted in another thread, I’m experiencing the same issue.

    Today I updated to the latest version of the plugin (v 2.1.15) and the issue persists. As someone else mentioned in yet another thread, this maybe happens due to the fact that the initial sync has to go through over 500 WC orders.

    I tried after setting up the cron job – same problem. Increased memory to 512M and even 768M – same. Increased the cURL timeout – same.

    The issue’s been persistent on the last three versions at least.

    This stops me from using MC for this customer, because their main interest is e-commerce email automation and e-commerce related campaigns.

    Only version 2.1.11 works fine, now. I get the same error with all proceeding versions including the latest 2.1.15.

    Hopefully there is a fix, soon.

    Version 2.1.10 results in the following error for me:
    API Key Invalid :: Your API key may be invalid, or you’ve attempted to access the wrong datacenter.

    Version 2.1.11 results in a message “401 unauthorized” next to the API field.

    Version 2.1.15 throws the same error as this thread.

    This is on a brand new installation with only approximately 60 users to sync.

    Plugin Support khungate

    (@khungate)

    Hi @nboot8, @kingyyyy, we just wanted to check back with you to see if this was still a problem with our latest plugin (2.1.16 at the time of this post). Please let us know when you get a moment, we’ll be happy to help troubleshoot further if necessary.

    Please note, the best way to reach us is over at the GitHub plugin page. From there, you can receive direct responses from the development team, log new issues and track existing ones.

    I look forward to hearing back from you all.

    Hi @khungate ,
    Because of this error I had already switched my customer’s site to another process, so I have no feedback at this time. Thanks for the information though, in case we want to consider it in the future.
    Best regards

    I can confirm the issue is still there with 2.1.16

    “Mailchimp says: API Request Error – cURL error 28: Operation timed out after 5001 milliseconds with 0 bytes received”

    Plugin Support khungate

    (@khungate)

    @joideas, I’m sorry you’re still having issues. We plan on releasing an updated version this week that may help around this problem for certain hosting environments. Would you care to download/update the plugin and report back when we do? Look for it in the 2.1.17 release.

    Plugin Support khungate

    (@khungate)

    Hi @username. We’re going to close out this ticket for now due to inactivity.

    Please let us know if you still need any help and we’ll be glad to reopen and troubleshoot further. Please note, the best way to reach us is over at the GitHub plugin page. From there, you can receive direct responses from the development team, log new issues and track existing ones.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.