Support » Plugin: Etsy Shop » API reponse should be HTTP 200

  • Resolved dcrowe13

    (@dcrowe13)


    Hello,

    Experiencing the feared HTTP 200 error. Switched to debug mode, here’s the output:

    Etsy Shop Debug Mode

    WP_Error Object ( [errors] => Array ( [etsy-shop] => Array ( [0] => Etsy Shop: API reponse should be HTTP 200 ) ) [error_data] => Array ( ) )

    live site

    Any help would be great. Thanks!

    http://wordpress.org/extend/plugins/etsy-shop/

Viewing 15 replies - 16 through 30 (of 37 total)
  • Hey!
    Still not working
    i change it to the correct id number:

    http://awesomescreenshot.com/07aq9miac

    Debug mode no active, still the API reponse should be HTTP 200 here:

    http://www.8-bitcrowd.com/portfolio/item-pilot/

    I think im missing something, should i change something?

    Thank you

    Plugin Author fsheedy

    (@fsheedy)

    Weird. If you go in debug mode you still have section id 117897648?

    In the screenshot, seem to be another page /shop, last URL you give to me was portfolio/item-pilot/. Maybe the problem?

    Yes, i change the name of the item! inside wordpress

    So, can be that the problem?
    Sorry i didnt know that i don’t have to edit the name.

    So i have to change the title of the item in my wordpress to my original one! right?

    Thanks

    I got it! sorry was my mistake, my items was duplicate and in one i have correct section ID and in other no, My mistake sorry!

    thnaks for your time and help

    I am new to WP.org and plugins. This is what I’ve done so far.

    1. Install plugin.
    2. Activate plugin.
    3. Made tmp folder read/write.
    4. Got my API key and it says it’s valid.
    5. Placed [etsy-include=TracyLogan;12050290] on a test post (Floorcloth section ID)

    My etsy site is: http://www.etsy.com/shop/TracyLogan
    My blog test page in debug mode is: http://www.tracyloganstudios.com/wp/hello-world/

    I have read through this forum topic and have tried a few things but I am still getting this error. I hope you can help me fix this issue. Thanks! 🙂

    Plugin Author fsheedy

    (@fsheedy)

    Hi,

    Here is the problem:

    You placed this:
    [etsy-include=<em>TracyLogan</em>;12050290]

    Instead of:
    [etsy-include=TracyLogan;12050290]

    Go to your post/page and remove the em tag. Should be ok after.

    Thanks fsheedy! That worked! When I copied it, it must have been in italics and I didn’t even think to check that.

    Plugin Author fsheedy

    (@fsheedy)

    logan3975: will be nice if you take time to do a review http://wordpress.org/support/view/plugin-reviews/etsy-shop

    Thank you!

    I’m about to give up on this. It seems easy enough, but no matter how much I double check, the correct command line does not seem to work.

    I am inputting the following tag line on my wordpress page

    [etsy-include=gallagherpottery;120832257]

    what I actually get on my page –

    Etsy Debug Mode – version 0.9.3 —

    Go to Etsy Shop Options page if you wan’t to disable debug output.

    — Etsy Request URL —

    http://openapi.etsy.com/v2/shops/gallagherpottery/sections/120832257/listings/active?api_key=mckwx9noxquuib1tncvh3jle&includes=Images
    — Etsy Response —

    Array ( [headers] => Array ( [date] => Wed, 23 Jan 2013 01:10:56 GMT [server] => Apache [x-ratelimit-limit] => 10000 [x-ratelimit-remaining] => 9987 [x-error-detail] => Not all requested shop sections exist. [x-etsy-request-uuid] => b1P7LkmMzHttg_buRFzKGLBj3S0Q [content-length] => 38 [connection] => close [content-type] => text/plain;charset=UTF-8 ) [body] => Not all requested shop sections exist. [response] => Array ( [code] => 404 [message] => Not Found ) [cookies] => Array ( ) [filename] => )
    Etsy Shop Debug Mode

    WP_Error Object ( [errors] => Array ( [etsy-shop] => Array ( [0] => Etsy Shop: API reponse should be HTTP 200 ) ) [error_data] => Array ( ) )

    Can someone please help???

    Now that I’m looking, I’ve provided the item id and not the section id. When I provide the correct section code, I get a huge string of text…

    — Etsy Response —

    Array ( [headers] => Array ( [date] => Wed, 23 Jan 2013 01:26:08 GMT [server] => Apache [x-ratelimit-limit] => 10000 [x-ratelimit-remaining] => 9984 [x-etsy-request-uuid] => D17vuEjBliI3YiP8f1z0tWccGGWn [connection] => close [content-type] => application/json ) [body] => {“count”:13,”results”:[{“listing_id”:120833190,”state”:”active”,”user_id”:9290251,”category_id”:69150451,”title”:”Carved Texture Star of David Cheese Tray”,”description”:”This hand built stoneware tray features a stamped, hand-carved original texture with an ivory glaze that breaks to a nutmeg, highlighting the texture. The hand pulled ‘loopy’ handles gives a bit of whimsey to the piece. It’s perfect for your favorite cheeses or appetizers, or, just to leave out and admire. The tray is approx. 9″ long and sits on 4 little clay feet.”,”creation_tsz”:1358468713,”ending_tsz”:1368763200,”original_creation_tsz”:1358468713,”last_modified_tsz”:1358902742,”price”:”35.00″,”currency_code”:”USD”,”quantity”:1,”tags”:[],”category_path”:[“Ceramics and Pottery”],”category_path_ids”:[69150451],”materials”:[],”shop_section_id”:12784991,”featured_rank”:0,”state_tsz”:1358468713,”url”:”http:\/\/www.etsy.com\/listing\/120833190\/carved-texture-star-of-david-cheese-tray?utm_source=etsyshopfornancygall&utm_medium=api&utm_campaign=api”,”views”:6,”num_favorers”:0,”shipping_profile_id”:157913529,”processing_min”:null,”processing_max”:null,”who_made”:”i_did”,”is_supply”:”false”,”when_made”:”2010_2013″,”recipient”:null,”occasion”:null,”style”:null,”non_taxable”:false,”Images”:[{“listing_image_id”:417242891,”hex_code”:”7B614C”,”red”:123,”green”:97,”blue”:76,”hue”:27,”saturation”:38,”brightness”:48,”is_black_and_white”:false,”creation_tsz”:1358468713,”listing_id”:120833190,”rank”:1,”url_75x75″:”http:\/\/img3.etsystatic.com\/014\/0\/5803560\/il_75x75.417242891_go81.jpg”,”url_170x135″:”http:\/\/img3.etsystatic.com\/014\/0\/5803560\/il_170x135.417242891_go81.jpg”,”url_570xN”:”http:\/\/img3.etsystatic.com\/014\/0\/5803560\/il_570xN.417242891_go81.jpg”,”url_fullxfull”:”http:\/\/img3.etsystatic.com\/014\/0\/5803560\/il_fullxfull.417242891_go81.jpg”,”full_height”:648,”full_width”:864},{“listing_image_id”:417242889,”hex_code”:”87745F”,”red”:135,”green”:116,”blue”:95,”hue”:32,”saturation”:29,”brightness”:52,”is_black_and_white”:false,”creation_tsz”:1358468713,”listing_id”:120833190,”rank”:2,”url_75x75″:”http:\/\/img1.etsystatic.com\/013\/0\/5803560\/il_75x75.417242889_ckk5.jpg”,”url_170x135″:”http:\/\/img1.etsystatic.com\/013\/0\/5803560\/il_170x135.417242889_ckk5.jpg”,”url_570xN”:”http:\/\/img1.etsystatic.com\/013\/0\/5803560\/il_570xN.417242889_ckk5.jpg”,”url_fullxfull”:”http:\/\/img1.etsystatic.com\/013\/0\/5803560\/il_fullxfull.417242889_ckk5.jpg”,”full_height”:648,”full_width”:864},{“listing_image_id”:417242899,”hex_code”:”866A51″,”red”:134,”green”:106,”blue”:81,”hue”:28,”saturation”:39,”brightness”:52,”is_black_and_white”:false,”creation_tsz”:1358468713,”listing_id”:120833190,”rank”:3,”url_75x75″:”http:\/\/img3.etsystatic.com\/010\/0\/5803560\/il_75x75.417242899_31s0.jpg”,”url_170x135″:”http:\/\/img3.etsystatic.com\/010\/0\/5803560\/il_170x135.417242899_31s0.jpg”,”url_570xN”:”http:\/\/img3.etsystatic.com\/010\/0\/5803560\/il_570xN.417242899_31s0.jpg”,”url_fullxfull”:”http:\/\/img3.etsystatic.com\/010\/0\/5803560\/il_fullxfull.417242899_31s0.jpg”,”full_height”:864,”full_width”:648},{“listing_image_id”:417242897,”hex_code”:”876B52″,”red”:135,”green”:107,”blue”:82,”hue”:28,”saturation”:39,”brightness”:52,”is_black_and_white”:false,”creation_tsz”:1358468713,”listing_id”:120833190,”rank”:4,”url_75x75″:”http:\/\/img1.etsystatic.com\/009\/0\/5803560\/il_75x75.417242897_cb1i.jpg”,”url_170x135″:”http:\/\/img1.etsystatic.com\/009\/0\/5803560\/il_170x135.417242897_cb1i.jpg”,”url_570xN”:”http:\/\/img1.etsystatic.com\/009\/0\/5803560\/il_570xN.417242897_cb1i.jpg”,”url_fullxfull”:”http:\/\/img1.etsystatic.com\/009\/0\/5803560\/il_fullxfull.417242897_cb1i.jpg”,”full_height”:648,”full_width”:864}]},{“listing_id”:120832257,”state”:”active”,”user_id”:9290251,”category_id”:69150451,”title”:”Floral Impression Stoneware Serving Basket”,”description”:”This sweet little hand built stoneware basket is just the right size for after dinner mints, olives or nuts. About 7″ long, it is made with espresso colored clay and stands on 3 sprigged feet. It has a hand pulled handle and is impressed with a floral decoration accented with a breaking ivory glaze and antique turquoise wash.”,”creation_tsz”:1358468116,”ending_tsz”:1368763200,”original_creation_tsz”:1358468116,”last_modified_tsz”:1358902742,”price”:”30.00″,”currency_code”:”USD”,”quantity”:1,”tags”:[],”category_path”:[“Ceramics and Pottery”],”category_path_ids”:[69150451],”materials”:[],”shop_section_id”:12784991,”featured_ra

    and on and on…

    please tell me what I’m doing wrong???

    Plugin Author fsheedy

    (@fsheedy)

    gallagherpottery,

    Unable debug mode and empty tge etsy shop cache.

    Let me know, should work without any problem.

    Thank you, that worked perfectly and the shop looks great w/the plugin! Will give a positive review for sure. Off to do it.

    -edit-
    SOLVED! I have made the same mistake as a lot of other people, I see. I should include the SECTION ID and not the ITEM ID.
    BTW: you can find this by clicking on one of your Etsy store Categories. It will include a whole category, not an item. Thanks Fsheedy, for making this plugin 🙂 -edit-

    hi Fsheedy,

    I’m also trying to get your plugin to work.
    I receive the following errors:

    At the plugin page:

    Warning: Invalid argument supplied for foreach() in /home/deb41906/domains/ginkgostudio.nl/public_html/wordpress/wp-content/plugins/etsy-shop/etsy-shop.php on line 375

    I want to include this item:
    https://www.etsy.com/listing/120363495/geometric-wooden-coaster-set-4

    And I use:
    [etsy-include=GreenWallNL;120363495]

    I’ve switched on debug mode, and get the following

    --- Etsy Debug Mode - version 0.9.3 ---
    
    Go to Etsy Shop Options page if you wan't to disable debug output.
    --- Etsy Request URL ---
    http://openapi.etsy.com/v2/shops/GreenWallNL/sections/120363495/listings/active?api_key=5yzqkgg5z8nep7pv5eg2y1c3&includes=Images
    --- Etsy Response ---
    Array ( [headers] => Array ( [date] => Wed, 23 Jan 2013 18:16:55 GMT [server] => Apache [x-ratelimit-limit] => 10000 [x-ratelimit-remaining] => 9996 [x-error-detail] => Not all requested shop sections exist. [x-etsy-request-uuid] => 77re_6JUpm5K8nEIDBuVVj1JC_Lt [content-length] => 38 [connection] => close [content-type] => text/plain;charset=UTF-8 ) [body] => Not all requested shop sections exist. [response] => Array ( [code] => 404 [message] => Not Found ) [cookies] => Array ( ) [filename] => )
    Etsy Shop Debug Mode
    WP_Error Object ( [errors] => Array ( [etsy-shop] => Array ( [0] => Etsy Shop: API reponse should be HTTP 200 ) ) [error_data] => Array ( ) )

    Any ideas?

    I am also getting the ‘API reponse should be HTTP 200’ error. Below is the output from debug mode. (When I copy the URL from the Etsy Request URL section into my browser, I get output that includes my shop listings from Etsy, so that seems to be working that way.) I noticed that the “presstheenvelope/sections/12998402” section of the URL is in italics — could that be causing the issue since the Etsy response shows formatting around that section of the URL in the debug details?

    Thanks,
    Katie

    --- Etsy Request URL ---
    http://openapi.etsy.com/v2/shops/presstheenvelope/sections/12998402/listings/active?api_key=4peenqdxy83gwbczfdvemxvw&includes=Images
    --- Etsy Response ---
    Array ( [headers] => Array ( [date] => Wed, 30 Jan 2013 01:06:37 GMT [server] => Apache [x-ratelimit-limit] => 10000 [x-ratelimit-remaining] => 9959 [x-error-detail] => The uri '/shops/<em>presstheenvelope/sections/12998402</em>/listings/active' doesn't map to a valid command [x-etsy-request-uuid] => otNBMqs2xFWkH9KwBGKJsug8eXcw [content-length] => 135 [connection] => close [content-type] => text/plain;charset=UTF-8 ) [body] => The uri '/shops/<em>presstheenvelope/sections/12998402</em>/listings/active' doesn't map to a valid command [response] => Array ( [code] => 404 [message] => Not Found ) [cookies] => Array ( ) [filename] => )
    Plugin Author fsheedy

    (@fsheedy)

Viewing 15 replies - 16 through 30 (of 37 total)
  • The topic ‘API reponse should be HTTP 200’ is closed to new replies.