Support » Plugin: Google Maps Widget » API problem with HTTP referrers

  • Resolved internationils

    (@internationils)


    Hello,
    I have:
    – installed the plugin
    – enabled both APIs
    – generated a key
    – tested successfully (both test button and the widget itself)

    The problem I have is that when I try to set the HTTP referrer domains, (domain.com/* and *.domain.com/*) the popup-map stops working (with the usual API not authorized message) for a referrer that has http://domain.com/blah/ The widget map still works (I assume that gets the base URL as referrer).

    In the API interface in google, the trailing wildcard is shown in the entry box, but not in the HTTP referrer once saved – could that be the problem?

    Any ideas?
    Thanks
    Nils

    https://wordpress.org/plugins/google-maps-widget/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author WebFactory

    (@webfactory)

    Hi,
    From the looks of it you did everything by the book. You have two solutions. First one is to wait a bit because those changes are not instant on Google, and the second one is to generate a new API key.
    Unfortunately, I don’t have “smarter” solutions 🙁

    Well, the changes work immediately when I add the referrers or remove them (inside if a minute or two), and I’ve already regenerated the key after ensuring both were enabled. Maybe somethings wrong on the google end with wildcards… if it would accept mydomain.com/* it would be fine, but the input field drops the “*” at the end.

    Plugin Author WebFactory

    (@webfactory)

    Did you just regenerate the key or create a new one?
    I can’t recreate the issue on my acc.
    Please also double check the key type. Should be browser.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘API problem with HTTP referrers’ is closed to new replies.