WordPress.org

Support

Support » Plugins and Hacks » [Resolved] API Key(s) not working with Akismet

[Resolved] API Key(s) not working with Akismet

  • I’m in the process of setting up a new wordpress blog (version 2.03) for a friend. I’ve turned on akismet (version 1.5), but when I enter a wordpress.com API key, it tells me “Your key appears invalid. Double-check it.”

    This happens with a key I’ve copied and pasted out of a wordpress.com profile, and also with a second API key which I’ve tried, which I’m already using successfully with Akismet on my own blog.

    Any suggestions on how to resolve this would be gratefully received!

Viewing 1 replies (of 1 total)
  • I’ve resolved this problem. I found this in the Akismet FAQ.

    My API key doesn’t work!

    We get this pretty often, try these steps:

    * Try the key again, after a few minutes.
    * Type in the key instead of copying and pasting it.
    * Ensure that your host can make outgoing HTTP requests to akismet.com. (Many hosts block or firewall outgoing connections.)

    I dropped an email to my host explaining the situation and asked if they were blocking outgoing requests. They said they were, but they’ve opened requests to akismet.com for me, and it worked straight away!

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] API Key(s) not working with Akismet’ is closed to new replies.