Support » Plugin: WordPress Site Speed Test Plugin - SpeedGuard » API key doesn’t seem to be working

  • Resolved dsecareanu

    (@dsecareanu)


    Hey there,

    I’ve went through the installation procedure, created the API key, but while it said it saved the settings, when tried to go to Speed Tests menu it gave the error of invalid API key.

    Browser console says the following:
    WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed: Error during WebSocket handshake: Unexpected response code: 403

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Sabrina Zeidan

    (@sabrinazeidan)

    Hi!
    That sounds unusual.
    1. Could you please specify the URL of the page (or make a screenshot) where you enter the WebPageTest API key?
    2. “when tried to go to Speed Tests menu it gave the error of invalid API key”
    If you could share an error message coming from the SpeedGuard as well, that would be wonderful.

    Thank you.

    The admin page is the following:
    https://test.com/wp-admin/admin.php?page=speedguard_settings
    Thanks!

    Plugin Author Sabrina Zeidan

    (@sabrinazeidan)

    The only thing I can imagine is that the test server might have some limitations for the outgoing connections.

    Strange. It’s a DO droplet with no outgoing firewalls… I will test on other websites on the same droplet and report back (this particular site was migrated from GoDaddy and might have some leftovers in its files).

    Plugin Author Sabrina Zeidan

    (@sabrinazeidan)

    Please, feel free to let me know how it goes!

    Same on another website as well (so is either the droplet or a security plugin). Might this conflict with any security plugin, i.e. Wordfence? Nothing shows up in the nginx logs.

    The error page (/wp-admin/admin.php?page=speedguard_settings) shows this:
    SpeedGuard :: Settings
    API key you have entered is not valid.

    Dismiss this notice.
    Toggle panel: API Key
    Enter API key:

    • This reply was modified 2 months, 2 weeks ago by dsecareanu.

    Ahahaha 🙂 sorry, found the issue.

    The API key starts with “A.” and was followed by a series of numbers and letters. Double click on it (the usual thing to select all) only copied the part after the “.” so, indeed, the API key was incomplete…

    Sorry to bother, but maybe the API key can be generated in some other way (it can also be confused with A. <this_is_your_api_key>. 🙂

    Plugin Author Sabrina Zeidan

    (@sabrinazeidan)

    No worries 🙂
    Good to know you’ve got that figured out!
    Yeah, I would love to see API key generated automatically from the dashboard too, but unfortunately, WebPageTest API doesn’t support this for now.
    Be sure, once it’s available I gonna updated this too.
    Cheers!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.