Support » Plugin: Mag products integration for WordPress » API enabled but not working

  • Resolved hayflick

    (@hayflick)


    Hello, I’ve already installed beeweb module to magento, attributed reading Guest roles in system config, and installed mag-integration to wp, htaccess is just fine as the rewrite rule for /api/rest/ is uncommented and directly under ‘#RewriteBase /magento/’, yet I can’t connect to magento api. And both api modules are enabled in configurations.

    Server is Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.6.40, has mod.rewrite enabled, and Magento is 1.9.3.2, Portuguese translated (no idea if that makes any difference).

    /api/rest returns:

    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
      <SOAP-ENV:Body>
        <SOAP-ENV:Fault>
          <faultcode>Sender</faultcode>
          <faultstring>Invalid XML</faultstring>
        </SOAP-ENV:Fault>
      </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>

    but /api.php?type=rest returns:

    <magento_api>
    <messages>
      <error>
        <data_item>
          <code>404</code>
          <message>Request does not match type route.</message>
        </data_item>
      </error>
    </messages>
    </magento_api>
Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘API enabled but not working’ is closed to new replies.