Support » Plugin: MailChimp Widget » API 3.0 and 0.8.12

  • I’m using this plugin on one of our websites but I can’t seem to be able to subscribe to the newsletter.

    The lists seem to be loading properly when adding the widget to the sidebar, I select the list, and in the front end, when subscribing to it, the ajax call is made, the success message is prompted but I don’t receive any email to subscribe to the list.

    Is this related to the fact that the api (1.3) is deprecated and you now have 3.0 running?

    https://wordpress.org/plugins/mailchimp-widget/

Viewing 2 replies - 1 through 2 (of 2 total)
  • The response im getting is:

    {“success”:true,”error”:””,”success_message”:”Thank you for joining our mailing list. Please check your
    email for a confirmation link.”}

    I checked the code and it seems like this:
    $subscribed = $mcapi->listSubscribe($this->get_current_mailing_list_id($_GET['ns_mc_number']), $_GET[$this->id_base . '_email'], $merge_vars);
    is returning true so it should subscribe me, correct?

    Please ignore my message… Emails were being sent to my clutter folder, so that’s why i couldnt see them.

    Great Plugin. Can I only suggest that you change a couple of static links you added? I use a custom folder for my themes and plugins (not wp-content) so I needed to change:

    private $default_loader_graphic = 'mailchimp-widget/images/ajax-loader.gif';
    
    $this->default_loader_graphic = plugins_url( $this->default_loader_graphic );
    
    public function add_scripts () {
    		wp_enqueue_script('ns-mc-widget', plugins_url( 'mailchimp-widget/js/mailchimp-widget-min.js' ), array('jquery'), false);
    	}

    Apart from that, keep up the good work 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘API 3.0 and 0.8.12’ is closed to new replies.