Support » Plugin: Latest Tweets Widget » APC and PHP 7

  • Hey!

    I just moved a website that uses your plugin to PHP7 and had the problem that PHP7 doesn’t contain APC by default. It’s required to install the package “apcu-bc” separately. Not every server does it.

    The plugin calls at least two functions for APC (apc_fetch, apc_store) without checking if they are available.

    Would be great if the plugin can test before using APC.

    Greetings
    derRALF

Viewing 1 replies (of 1 total)
  • Likewise had same issues on Kinsta. I worked around by changing line 19 in wp-twitter-api/lib/twitter-api-core.php to define('TWITTER_CACHE_APC', 0 );. This forces the plugin to use a WordPress transient.

Viewing 1 replies (of 1 total)
  • The topic ‘APC and PHP 7’ is closed to new replies.