Apache Ping problem, advice needed ASAP (15 posts)

  1. resist
    Posted 10 years ago #

    I need an advice on the apache configuration. The problem is that I moved my site (and everything else to a different server, everything stayed the same, except of the hardware, my works just fine there, except of the dashboard feed that stays empty. I tried installing WP on a different server and the dashboard works great without any problems. However, I think my apache cfg (Apache/1.3.33 (Debian GNU/Linux) PHP/4.3.10-15 ) got bad. I noticed the pinging problem with WP when I tried to ping google the first time while installing the so-called Google SiteMaps plugin for WP, it gave me "Cant ping Google " message, so I had to add my sitemap's url by hand, via google panel.

    I cant check if my website pings ping-o-matic and other services I have on the list, but this problem with dashboard's rss feed seems to have the same origin - inability to ping (update feeds) of/by my site from a remote server.

    I’m not an apache guru, so I would appreciate any suggestion on what might be causing this, as most likely it's something wrong with the apache cfg, but not sure.

    thx in advance.

  2. resist
    Posted 10 years ago #


  3. skippy
    Posted 10 years ago #

    Try to use RedAlt's ping test tool to see if you can send pings.

    It might be that your host has disabled allow_url_fopen in php.ini.

  4. Beel
    Posted 10 years ago #

    Whenever I attempt a ping from RedAlt to any post, I get a faultcode "not well formed" - anyone know how to "decode" the error so I can fix my ping reception?

  5. resist
    Posted 10 years ago #

    I tried to post this

    testing the pinging service of the server http://redalt.com/ping

    and Ive got

    RedAlt has no record of pingbacks or trackbacks from sites beginning with the submitted string.
    Be sure that your URL begins with "http://".

    I have full access to any configuration files of the server, so plz post your suggestions. (Im checking the php.ini right now)

  6. resist
    Posted 10 years ago #

    well I checked php.ini and it's allow_url_fopen = On
    any ideas?

  7. resist
    Posted 10 years ago #

    Yeah looks like it does not send pings or trackbacks at all. What should I do?

  8. skippy
    Posted 10 years ago #


    Have you tried re-installing the WordPress files on this blog? You can safely delete all the files, then re-upload fresh copies, without causing any damage to your database. Backup your theme, if you made any changes.

    Are you runing any plugins?

    Are you firewalling out-going connections from your webserver?

  9. resist
    Posted 10 years ago #

    yes I tried re installing the wordpress, but it's not the problem of the engine. I do have 2 plugins: ip2nation and google site maps, but disabling them doesn’t make any difference, besides I've been using them for a long time.
    Are you firewalling out-going connections from your webserver?
    Im not really sure, because the server is 5000 km from me, any way to check it?

    Moreover, is there any specific apache file that may be the source of the problem? Any specific or related cfg file or something?
    Because I still think it has something to do with apache server (used to have 2.054 on my previous configuration (no problem at all), but it was buggy by itself, stoping randomly, so 1.33 was installed back).

  10. skippy
    Posted 10 years ago #

    I used to use Apache 1.3.x and had no trouble sending pings.

    If you have command-line access to your server, try any of the following:
    wget http://www.google.com
    lynx http://www.google.com
    curl http://www.google.com

    Basically you're trying to determine if you can make outgoing connections from your server to the internet. If you cannot, then this would be the cause of your pingback problems. If you can, then we're back to square one.

  11. resist
    Posted 10 years ago #

    well I tried wget with with root shell (but my site is in a separate folder) and it works.
    Dont know what to check next =(

    Maybe it has something to do with user permissions for the folder or something (in my case just a standard var/hosting/UserName/www format? )

  12. resist
    Posted 10 years ago #

    So, any other files I should look at?

  13. resist
    Posted 10 years ago #

    At the same time I found that everything works fine on a different server with allow_url_fopen Off in php.ini and does not work at my usual server with allow_url_fopen On as I stated b4.

    So Im not sure if allow_url_fopen has anything to do with this at all.

  14. skippy
    Posted 10 years ago #

    Have you looked in your Apache error log for anything? Try to post, and ping a site. Then immediately check your error log. Also check the server's syslog, if you have access, to see if anything is being recorded there.

  15. resist
    Posted 10 years ago #

    well no any errors related to this
    I feel there is a major cfg/permission bug somewhere that does all this.
    But I have no clue where to search for it.

    # mysite
    <VirtualHost xxx.xx.159.146>
    ServerAdmin admin@mysite.info
    DocumentRoot /var/hosting/mysite/www
    ServerName http://www.mysite.info
    ServerAlias mysite.info
    ErrorLog /var/hosting/mysite/log/error.log
    CustomLog /var/hosting/mysite/log/access.log common
    <Directory /var/hosting/mysite/www>
    Options FollowSymLinks
    Options +Includes
    AllowOverride All
    Order allow,deny
    Allow from all

    It sounds stupid, but wp works even at freeserverhost.com for me, dashboard, pings... everything works, and here I cant make it work on my own server! Would php info file be of any use?


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.