WordPress.org

Support

Support » Plugins and Hacks » Redirection » [Resolved] Apache Location directive ignored after installing Redirections

[Resolved] Apache Location directive ignored after installing Redirections

  • I have launched a new west site that uses WordPress as the home page. After installing and setting up several redirections for out of date URLs, I noticed a URL used for a web service was not working. I assume it stopped working after WP was annointed as the primary web site for the server.

    For example, redirecting this…
    /products/prod1/index.html
    to…
    /products/new_product
    works just fine.

    The URL that does not work is defined in the Apache config using the Location directive for a given web service, e.g.

    <Location /wsA>
    WSserver 127.0.0.1 xxxx
    sethandler ourHandler
    </Location>

    What happens is the WP 404 page is displayed. The correct result is an information page generated via the web service.

    Is there a way to configure Apache and/or Redirections to process the webservice URL as it did in the past?

    Do I need to separate the public web site and web service domains entirely?

Viewing 1 replies (of 1 total)
  • Well, after a bit research, a refresher on mod_rewrite, and some thinking on the cool side of the pillow, I found the answer.

    The unwanted 404 began when I enabled pretty URLs in WordPress. This added a block in the htaccess file in the document root of the web site. In the .htaccess document, within the wordpress block, and after the RewriteEngine and RewriteBase directives, I added one rewrite rule:

    RewriteRule ^wsA(/|$) - [L,NC]

    How the rewrite rule works is explained here: How do I ignore a directory in mod-rewrite

    I hope this helps someone.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Apache Location directive ignored after installing Redirections’ is closed to new replies.
Skip to toolbar