Support » Plugin: Edge Cache HTML via Cloudflare Workers » Apache Error Log and Admin Error

  • Resolved Voice4Vision

    (@voice4vision)


    I get the following error in my error log….

    [Wed Jan 15 01:32:15.172153 2020] [proxy_fcgi:error] [pid 9953] [client 127.0.0.1:46176] AH01071: Got error ‘PHP message: PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘Cloudflare_Edge_Cache_Admin_Settings’ does not have a method ‘km_hook_into_options_page_after_save’ in /home/***.*********.***/*********/public_html/wp-includes/class-wp-hook.php on line 290′, referer: https://***.*********.***/wp-admin/plugins.php?page=cf_caching_options

    In the Cloudflare Edge Caching Settings, I see the following message…

    Current Cloudflare Worker installation status: Could not route to /accounts/workers/scripts/wp-edge-caching, perhaps your object identifier is invalid?. Code 7003

    I am certain that my cloudflare worker has been properly setup as per your instructions. I have NOT edited the

    const CLOUDFLARE_API = {
    email: “”, // From https://dash.cloudflare.com/profile
    key: “”, // Global API Key from https://dash.cloudflare.com/profile
    zone: “” // “Zone ID” from the API section of the dashboard overview page https://dash.cloudflare.com/
    };

    As I am using KV, not API.

    Any ideas as to what maybe wrong?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author s1lviu

    (@s1lviu)

    Hi @voice4vision

    Can you update and retry?

    Thanks

    Voice4Vision

    (@voice4vision)

    Updated to 1.0.3 and retried. I get the same result

    Plugin Author s1lviu

    (@s1lviu)

    Does that error still appear?

    I have tested it only with a free account. I will take a look at KV and give an update.

    Thanks

    Voice4Vision

    (@voice4vision)

    Yes both errors are still present

    Voice4Vision

    (@voice4vision)

    I have a pro account if you would like to test on that!

    Plugin Author s1lviu

    (@s1lviu)

    If you want, you can share access with wordpress_development at protonmail d0t com

    Plugin Author s1lviu

    (@s1lviu)

    @voice4vision
    I made some fixes in 1.0.5 version.
    That error from your logs should not appear anymore and you should be able to install the worker now from the plugin settings page.

    Please, confirm it’s ok now.

    The support for KV will come soon.

    Thanks

    Voice4Vision

    (@voice4vision)

    AWESOME…

    Everything is working as expected.

    Thank you so much.

    Plugin Author s1lviu

    (@s1lviu)

    Great.
    If you like the plugin, a review will be much appreciated!
    I’ll close this issue now.

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Apache Error Log and Admin Error’ is closed to new replies.