Support » Fixing WordPress » apache 2 problem solved?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’ve been running WordPress with Apache 2, PHP5 and MySQL 4.1 since the alpha stage with no problems (aside from bugs in the alphas, natch).

    Peering through some of those posts, a couple of things spring to mind.

    If WP is consistently sticking a \ in front of " characters, check to see if “magic_quotes” is on or off in your PHP config. I believe it’s behaviour changed between PHP4 and PHP5, so try setting to the opposite value and see if that gets fixed. PHP5 also has a PHP4 compatibility mode, but my understanding is that it’s not great and can cause it’s own problems. If you’re running PHP5, then PHP4 compatibility should be turned off.

    PHP4 and MySQL 4.1 don’t get along well without a little hacking on MySQL, so it’s not a recommended combination. People with login or certain installation problems might be experiencing a symptom of this configuration.

    If you’re running Apache under Windows, it can run either in the system account or an account you specify. If you’ve installed Apache with it’s own Windows username (or if your host has), this might be a simple permissions problem that can be solved by elevating the Apache user’s permissions on the folder containing the htaccess file. Windows can also have difficulties with files that only have an extension for a name (like .htaccess), so that might be a problem if the latest updates and versions aren’t installed.

    Good luck 🙂

    i turned off magic_quotes on my php5 config. and lookee here: the dashboard has magically appeared.
    the backslash problem in pages has also been solved in that way.
    but for some reason the plug-in problem persists.
    whenever i click to activate a plug-in a blank page will load. this happens with all plugins, even with the basic plugins like hello dolly etc.
    that is actually the show-stopper of the issues. any pointers on that?

    but thanx so much for this info, man.

    here’s the error message i receive:

    Warning: Invalid argument supplied for foreach() in /home/public_html/wordpress/wp-settings.php on line 113 Warning: in_array(): Wrong datatype for second argument in /home/public_html/wordpress/wp-admin/plugins.php on line 9 Fatal error: [] operator not supported for strings in /home/public_html/wordpress/wp-admin/plugins.php on line 10

    Have you tried running the upgrade.php file in the /wp-admin folder? Even if you have, try running it again, just in case. That really looks like the errors you’d get if the options table is in the 1.2 format instead of the 1.5 format.

    Glad the other problem is solved 🙂

    i can try doing that, but this is a clean 1.5 test-install, not an unpgrade install.
    edit: surprisingly that did fix it, but i dont understand, as this was a clean brandspanking new test install. oh well, i am not arguing, it works it works, right…

    I updated that first mosquito issue linked to in the first post on this thread with how I got permalinks to work.

    Basically, as superuser run the command:

    a2enmod rewrite

    More information in the mosquito issue under the username lev.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘apache 2 problem solved?’ is closed to new replies.