Support » Plugin: Autoptimize » ao_speed_cachebuster High CPU usage and multiple requests

  • Resolved drazon

    (@drazon)


    I noticed high cpu usage in 1 dedicated and 1 vps server both of them host more than 10 websites and (almost) all websites presented the high cpu usage issue with ao_speedup_cachebuster. I read the forums that it may have to do with memcache or something related.

    What I can say for now is that on both servers (both on WHM/cPanel CentosOS 6 latest) this appeared after yum update and server reboot. So far I have excluded the linux kernel. I have to check/debug all other stuff which got updated during the last yum update.

    Another thing I can say is that Super Cache can’t cache neither can preload the cache. If anybody has the same issues please share your feedback.

    I don’t think it’s an autoptimize issue it worked perfectly fine just before the yum update, however I’m posting this here to collect information from others that might experiencing the same issues.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    typically the cache-buster requests are done upon the cache being purged, which _should_ not be often. there are however plugins and one much used premium theme which call AO’s cache purge very regularly, which can cause issues. AO 2.5 (likely to be released this weekend) will prevent the cache-buster to be called too regularly (max once per 10 minutes), so that should limit the impact somewhat.

    pretty weird wp super cache doesn’t work any more either, filesystem permission problems maybe?

    I know Frank, I read the forums and your feedback is much appreciated. I ‘m sure I’m going to have some news in the next few hours, I’m pretty sure also autoptimize and Super Cache have nothing to do with the source of the problem. I use both of them on every setup. I’m examining crons now and I think I might have found something. I’ll update this again soon.

    Having same issue. Looks like about a day ago this started. Seems to be in conflict with WP Super Cache. The strange thing is that my cache plugin was last updated 4 months ago, and I’ve been using these 2 together for years. No changes were made to the site or plugins.

    I’ve went through purged and rebuilt the wp super cache ‘cache’ with autoptimize disabled, then re-enabled and that doesn’t seem to have helped. I tried also limiting features and options with both plugins.

    Right now I have left autoptimize disabled to keep the website up, otherwise this will generate a error 500 for our users.

    • This reply was modified 1 month, 1 week ago by  bofslime.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    @bofslime you likely have an updated plugin (or theme, Divi is an example) that erroneously thinks clearing the cache is a good idea, try identifying which one does so. The AO update that is near will also prevent the “cache busting” happening more then every 10 minutes, so that should at least prevent the 500’s .

    Good day, I found the source of the problem here, The same day with the yum update I did, I checked if there were any plugins updated as well because I confirmed that it didn’t happen on all websites.

    The most common suspects in this case are security plugins, in my case I noticed that one security plugin “WP hide & security enhancer” got updated the same day. I looked at the changelog and I saw that it had wp cron related updates. Something caused the same crons to be fired multiple times. I disabled all 3 plugins AO SC and WP hide, reactivated them, I made sure to recreate the rewrite rules of the WP hide again and flushed all caches. Now all websites are up running again.

    Look if you have the same plugin installed or any other security plugins. Look which plugins got updated the same day. If that doesn’t help try to test a fresh WP install with AO and Super Cache only to see if there are any issues. As I initially thought AO and SC didn’t cause any issues.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    That’s real interesting feedback, thanks @drazon !

    Sorry, I guess I should have been more clear. I tested the issue clear with AO enabled and only SC disabled. I do have WP hide, but this was not causing the issue for me. My theme also does not seem to be a problem the issue is only found when AO and Super Cache are enabled.

    I’m watching a tail of my log while enabling disabling plugins to quickly identify which is causing the conflicts. It is error free with AO enabled, and only SC disabled.

    • This reply was modified 1 month, 1 week ago by  bofslime.

    Did you try to disable WP HIde then make sure your htaccess is the default one and enable SC and AO with a default WP theme?

    Well, now I seem to not be able to replicate it. I just enabled AO with SC, and it’s not erroring as it did before. I did previously test AO and SC with WP-Hide disabled, and the issue was present. So I left AO disabled over night, and now testing it again it’s behaving.

    I’m on shared hosting environment, so I’m not sure if my host has done anything.
    I’m 100% back to my original state, now without the cachebuster loop. This is so strange.

    • This reply was modified 1 month, 1 week ago by  bofslime.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    maybe reach out to the “wp hide” devs to tell them there’s an issue with there latest update @bofslime & @drazon ?

    Yeah, that does look to be it. WP-Hide updated on April 16th at 1300, and I see the cachebuster loop starting at 1302. What is weird to me is that I didn’t make any changes to wp-hide to “fix” it, and I had troubles with wp-hide disabled between AO and WPSC. I suppose its possible that something with wp-hide got cached in WPSC.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, based on what drazon wrote, wp hide somehow messed up cron schedules, which would impact other plugins as well even if wp hide was disabled?

    akiraanastasia

    (@akiraanastasia)

    Same problem here. I am using same plugins as above. BUT problem is still there. Please help. All my sites are down with 503 error because of heavy resource use.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    this problem is caused by problems with the “wp hide” update, see https://wordpress.org/support/topic/ao_speed_cachebuster-high-cpu-usage-and-multiple-requests/#post-11441511 for info on how @drazon was able to fix @akiraanastasia

    AO 2.5 (out in a couple of hours) will limit the impact somewhat as well (by not allowing the cache-buster logic to run more then 1 every 10 minutes).

    frank

    tdgu

    (@tdgu)

    Hey everyone, i’am the developer for WP Hide plugin.
    So far i was not able to replicate the issue on this side, can you share more details regarding the plugins set-up?
    For WP Hide, at Rewrite > Root Files > Block wp-cron.php which is the selection you used? Changing that, does makes any change?

    Thanks

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.