Support » Plugin: Autoptimize » AO Conflict in presence of Style tag: Error 500

  • Resolved Gulshan Kumar

    (@thegulshankumar)


    Hi,

    With <style> … </style> tag in my about page
    When AO is active, HTTP 500.
    If AO is deactivated, HTTP 200.

    Alternate case
    When I remove <style> … </style> tag, site load in AO active mode also.

    Other pages are working fine as normal. I tried in other browser also.

    Ref: Watch Or Download Video

    Thanks & Regards,
    Gulshan

    • This topic was modified 1 year, 4 months ago by Gulshan Kumar. Reason: Made Title more clear
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Hey Gulshan;
    I had a look and I see that your about page has HTML in a style tag;

    
    <style>
    #mlb2-7302514 .subscribe-form .form-section h4 {<br />
        font-size: 20px !important;<br />
        display: none !important;<br />
        width:50%;<br />
    }<br />
    </style>

    I’m not 100% sure, but that might very well break the CSS minifier. Can you check if fixing the CSS fixes the HTTP 500?

    frank

    Gulshan Kumar

    (@thegulshankumar)

    Hi,

    That inline CSS containing br tag, I have fixed it. Still, error 500 I see as long below CSS is present

    <style>
    img.centered, .aligncenter {
        -webkit-box-shadow: none;
        -moz-box-shadow: none;
        box-shadow: none;
    </style>

    As I remove this, site up.

    Thanks

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    that one is missing a closing }, can you try adding that Gulshan?

    Gulshan Kumar

    (@thegulshankumar)

    I see there } was missing which was causing issue. As I added, AO is working fine.

    Thanks for the help. You are awesome!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    you’re welcome Gulshan, feel free to leave a review of the plugin and support here! 🙂

    Gulshan Kumar

    (@thegulshankumar)

    Sure, Happy to share my experience. 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘AO Conflict in presence of Style tag: Error 500’ is closed to new replies.