• Resolved mmxxi

    (@mmxxi)


    I’m not sure if it’s due to Twentig (Version 1.3.9) or something else, but after activating the Twenty Twenty-Two theme i’m only getting a white page of death for the new Site Editor (beta) and for Customize.

    On WordPress 5.9 that is (and WordPress 5.9.1-alpha-52643 as well).

    • This topic was modified 2 years, 3 months ago by mmxxi.
Viewing 15 replies - 1 through 15 (of 30 total)
  • Plugin Author Twentig

    (@twentig)

    Hi,

    Thanks for your feedback. We can’t reproduce the issue. Have you tried to deactivate Twentig and then activate the Twenty Twenty-Two theme to see if you still have the issue?

    Thread Starter mmxxi

    (@mmxxi)

    I have tried deactivating all plugins, also now in that order, but the result is the same. Site is working, but i can’t access the Editor. Even without enabling any plugins. Or in a different browser.

    Just not sure that simply deactivating Twentig is enough. Or if removing it completely would leave a trace anyway.

    Really haven’t done anything strange with the site, except to redirect it to a subdirectory. It has just been for testing so far.

    Probably best to try a new install.

    • This reply was modified 2 years, 3 months ago by mmxxi.

    Im using Twenty Twenty Two (5.9) on https://commadot.com
    I had to disable Twentig, but really want it back for
    1. Google font choices
    2. Grid style

    But its working so far.

    Thread Starter mmxxi

    (@mmxxi)

    Those Google font choices are really nice.

    Have you tried editing your Latest Posts page with a Query Loop Block?
    https://wordpress.org/support/article/site-editor/#how-to-customize-your-homepage
    >>

    Query Loop Block

    • This reply was modified 2 years, 3 months ago by mmxxi.
    • This reply was modified 2 years, 3 months ago by mmxxi.

    I have the same problem. I got a white page for the new Site Editor (beta).
    But it works well in the WordPress App in my mobile phone.

    Here is the error msg in chrome in PC broswer:

    Uncaught (in promise) TypeError: Cannot destructure property 'id' of '(intermediate value)' as it is null.
        at K (edit-site.min.js:2:12033)
        at K.next (<anonymous>)
        at Y (edit-site.min.js:2:12469)
        at Y.next (<anonymous>)
        at redux-routine.min.js:2:9334

    Who can help me please?

    • This reply was modified 2 years, 3 months ago by pftsoi.
    • This reply was modified 2 years, 3 months ago by pftsoi.
    Thread Starter mmxxi

    (@mmxxi)

    Also note that i have a topic about it here:
    https://wordpress.org/support/topic/site-editor-loading-insecure-resource-http/

    Seems it is not related to Twentig, at least for me. But something in WordPress’ coding causing it to try and load the editor without SSL (on my hosting).

    Solved: white page for the new Site Editor (beta)

    Just restore “.htaccess” file, and the white page problem was solved.

    Before, according to some suggestion from net (https://free.com.tw/wordpress-optimization-guide/), I added some lines to optimized wp, it was said that it could remove Unnecessary query parameters (“移除掉不必要的查詢參數”). Now it makes the problem. The code like this:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{QUERY_STRING} !=””
    RewriteCond %{QUERY_STRING} !^p=.*
    RewriteCond %{QUERY_STRING} !^s=.*
    RewriteCond %{REQUEST_URI} !^/wp-admin.*
    RewriteRule ^(.*)$ /$1? [R=301,L]
    </IfModule>

    just remove these lines.

    Thread Starter mmxxi

    (@mmxxi)

    Not for me, and i don’t think i’ve made custom changes.

    It look like this, even if i let WP 5.9 create a new one:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /wp/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wp/index.php [L]
    </IfModule>

    @mmxxi I installed twice wp 5.9. One on https://commppress.nl/cammping and one with http:/www.commppress.nl/camping2. In the first one the site editor delivers a blank page,
    in the http version everything is normal.

    Thread Starter mmxxi

    (@mmxxi)

    @jvdbol Zit je toevallig op Vimexx?

    Makes sense. The error (for me) is caused by a http request on a https site. If the site is already http-only, then there is no error.

    But we should really use https/SSL in 2022.

    Ja, ik zit inderdaad op Vimexx. I am not sure if the problem is caused bij the provider or somewere by WordPress.

    Thread Starter mmxxi

    (@mmxxi)

    Dat is dan wel heel toevallig. Aangezien het lijkt of we de enige zijn met dit https probleem in de editor en we zitten allebei bij Vimexx. Ik had al contact opgenomen, maar helaas is het weekend.

    @mmxxi same problem here. Completely new installation of wp 5.9 in a subdir with twenty-twentytwo theme, no plugin at all. The problem is caused by /{subdir}/wp-admin/site-editor.php requesting /{subdir}/?_wp-find-template=true over http.
    Trying various workarounds, will update you if I get anything.

    Ok I just deleted everything and reinstalled wp from scratch, this time not in a subfolder but in the root.
    No more blank screen on 2022 theme’s edit: all is working now.

    So what’s that? An ssl propagation issue? (I don’t know if I’m using the right terms but I hope the question is clear).

    • This reply was modified 2 years, 3 months ago by Marks1973.
    • This reply was modified 2 years, 3 months ago by Marks1973. Reason: changed "answer" to "question" in the last sentence
    Thread Starter mmxxi

    (@mmxxi)

    I have no idea, but that’s very interesting.

    Gives us a workaround at least.

    Would prefer to keep using a subfolder though!

    Is WP to blame here, or the hosting?

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Anyone try the Twenty Twenty-Two theme?’ is closed to new replies.