Support » Plugin: Import from Ning » Anyone supporting this plugin – help w/ discussions

Viewing 15 replies - 1 through 15 (of 59 total)
  • I’m in the same boat!

    Same for me. I really tested it through. I learnt to completely understand the buddypress and bbpress relationship. I went back to older versions of buddypress (1.6.5) when the forums still were running- No way to import forums.

    OK, after some work on those files I got one step further. At least in my case the JSON files for discussions (ning-discussions.json and ning-discussions-local.json) were formatted in the wrong way. Both had one “]” too much at the end of file.
    Fortunately you can load those files into any editor, go right to the end of the file and delete the brace. And I said editor! Not Word or any Tex processor…
    So the files get loaded and it imports groups at least… unfortunately not yet the content….
    I’ll try again.
    Regards,
    Benny

    Thanks bschaich.

    This has been frustrating not being able to import discussions.

    My json file has this at the end “}]}]])

    Can you tell me what to delete?

    Thanks

    This is the issue i am having. when i try to import groups or discussions, it get this error message:

    “It looks like you’ve either disabled group forums, or you haven’t set them up correctly. If you don’t plan to use forums, click Continue. Otherwise, ensure that your forum setup is complete, and then return to this page.”

    I have bbPress setup the way they instruct. Forums are no longer a part of bp.

    any help appreciated. Looks like author has abandoned this plugin. for obvious reasons.

    Hello,
    I ran in the same issue but now it is resolved. It seems the problem is that the plugin was designed for import into buddypress forums, not bbpress ones. So you must activate and configure buddypress forums and the plugin will work out of the box (assuming your json files are correct).

    1)Go to plugins->installed plugins->buddypress->settings->Components->retired and activate group forums (legacy). Save settings, a “Forums” tab appears.
    2)Click Forums tab, in the left side, click on Install Group Forums.
    3)Then you’ll need to create a new page or use an existent one in order to assign “Discussion Forums” to it (in Buddypress Settings->Pages). Save settings and should it appear a message bar standing for generate config file or repair or something similar (I’ve a fish memory, sorry), click it. It will fix your config file path in buddypress->settings->settings tab->legacy group forums.

    And that’s all, now it will work or so did it for me.

    In case you want to use bbpress forums, you can now import data to bbpress from buddypress forums in tools->forums->import forums from bbpress1. (You can follow the guide in http://codex.buddypress.org/getting-started/guides/migrating-from-old-forums-to-bbpress-2/ )
    Hope it helps.
    Regards,
    Xavi

    My json file has this at the end “}]}]])

    Rockethead: the double ] at the end was my problem and I’m almost sure you can delete it and that should get you a step further.

    Again the bbpress/buddypress forum issue: keep an eye on the supported version numbers. Was very important to me, as it seeems they even dropped of the code in later versions. The plugin says it’s compatible up to 3.5.1 and buddypress 1.7.
    This ones look much different than newer releases.
    I personally went down to buddypress 1.6.5, as that was the last release that fully supported buddypress forums.
    Next I’ll try what Xaviote has done… but that already feels familliar.
    Regards,
    Benny

    I gave it a shot using WP 3.5 and BP 1.6.5 and everything and still no forums (or “discussions” as they’re called in the JSON files. I made sure there was no instance of “]])” in my JSON files as well. The only error the plugin did throw was:

    Fatal error: Class 'TribeEvents' not found in /Applications/AMPPS/www/dev.domain.com/wp-content/plugins/import-from-ning/bp-functions.php on line 1067

    I then updated BP to the latest version and tried the legacy route mentioned above by Xaviote. The plugin reports that the discussions were imported but alas the forum is empty. Anyone else havin’ luck? Any other advice from Xaviote or bschaich?

    Hello,

    I had it working with wordpress version 1.7.1, buddypress version 1.8.1 and bbpress version 2.5.
    I think the key here is the bp_ning_import_get_groups() function in bp-funcions.php from the plugin. This piece of code:

    if ( bp_is_active( ‘forums’ ) ) {
    groups_new_group_forum( $group_id, $group->title, $group->description );
    echo “$group_key) Created group: $group->title“;
    if ( !$forum_id = groups_get_groupmeta( $group_id, ‘forum_id’ ) ) {
    echo ”     Could not create group forum for $group->title”;
    }
    }
    MUST work in order to get discussions imported later, so the test
    bp_is_active( ‘forums’ ) MUST work, hence buddypress forums must be active and running.
    Edit: I haven’t seen the last post at the time of writing this. The empty forums you mention are the bbpress ones? Have you looked at buddypress ones (through the slug you configured before import)??
    Regarding events issue, did you see the thread:
    http://wordpress.org/support/topic/issues-halting-r-revolution?replies=3

    Thanks Xaviote! I didn’t have bbPress activated since I thought you had to import the forum discussion data to the BP legacy forums (“retired”) and THEN port them to bbPress.

    Made sure that the forums are active and tried again but to no avail. Any other idears?

    Hey guys thanks for this info.

    Xaviote i didn’nt even see the retired link in components. Lol. Thank you so much.

    Since i’ve activated and mapped bbpress to the certain groups, how will importing now affect my structure?

    Do you recommend any additional steps to make this a smooth process?

    Thanks again

    Thank you so much for the information. I am currently trying to import all content from NING to Buddypress and I received the same error as rockethead2 – From reading your posts I see the ‘retired’ forum so I have activated it and will try to import the discussions again this weekend.

    There was one thing that I was wondering… Does the discussions import include the comments members have written on the comment walls? Replying to blogs and pages (not just forum topics).

    If I understand it correctly my endless tries of importing forum discussions works just fine for the member activity comments. Those end up as posts under Activity in BuddyPress. It’s the forum stuff that I can’t get in (even though the plugin says it has imported it properly). Hope you have luck with it westyalf! I look forward to hearing how it goes. I’m giving up for now and trying to get the forum info into phpBB for my client to use in transition to a totally fresh new social network on BuddyPress and bbPress. Feeling at wits end!

Viewing 15 replies - 1 through 15 (of 59 total)
  • The topic ‘Anyone supporting this plugin – help w/ discussions’ is closed to new replies.