Support » Themes and Templates » Anyone care to help with br tags?

  • isdereks

    (@isdereks)


    i’m in the process of creating a theme from scratch for my personal site at http://5thirtyone.com/ and am in a little bit of a rut.

    i have the base template up and running. nothing but active posts. everything else (comments, category links, etc.) will be added later.

    i noticed that my tags are not displaying correctly after i save posts.

    if anyone has some time i’d appreciate it if someone could point out my mistake.

    edit: after looking at the code it looks like the br tags are being removed and replaced with p tags. any insight?

Viewing 7 replies - 1 through 7 (of 7 total)
  • moshu

    (@moshu)

    If you are using the RTE:
    Enter = p tag
    Shift+Enter = br

    isdereks

    (@isdereks)

    the issue isn’t inserting tags. it’s the way wp is being rendered. the br tags are not showing up in posts. i tried using both the rich text and plain html editor to add the tags but they are never displayed in the posts.

    moshu

    (@moshu)

    What do you mean by “displayed”?
    When looking at the source code of your site I see this:
    during these last three days.<br />

    isdereks

    (@isdereks)

    see the screenshot

    http://img235.imageshack.us/img235/6678/capture0se.jpg

    there should be a line break after ‘three days’.

    Direkt

    (@direkt)

    — What? That looks like a line break. You have to do double <br> to have a line between. It’s always been that way.

    moshu

    (@moshu)

    there should be a line break after ‘three days’.

    There is.

    isdereks

    (@isdereks)

    sorry. i was doing doubel br tags.

    i fixed the issue by removing the ie hack in the stylesheet. thanks guys.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Anyone care to help with br tags?’ is closed to new replies.