Support » Plugins » Anybody get Videopress working?

  • I have tried to get videos from Videopress to play on all my WordPress installations. But the video just doesn’t show up. I’ve installed the Videopress plugin. Do I have to do something else?

    Here’s the short code that spits out when I upload the video: [wpvideo dbsa40SD]

Viewing 11 replies - 1 through 11 (of 11 total)
  • This is how I got it to work – and it’s a little “involved”… but I really like the way the video looks in the post, so it’s worth the trouble as far as I’m concerned.

    You got the uploading part right, just MAKE SURE you have the embed code enabled (“Display embed code and allow external sites to embed this video” checkbox) – do that on wordpress.com.

    Next, make a post (but don’t actually post it) in wordpress.com, with the video inserted – in the body of the post simply put that code [wpvideo dbsa40SD] then preview the post. Select EMBED (upper left in the video) and “Copy to Clipboard” next to the code listed under “Embed this video on your webpage”.

    Make your post on your wordpress.org site, pasting the code in the HTML view where you want it in the post.

    Here’s the kicker – you CANNOT turn off the EMBED option in the video in the media library on WordPress.com, or the video in your blog (or anywhere else it’s embedded) will GO BLACK. However, you do not have to save the wordpress.com POST you made, you can delete that entirely.

    You’re restricted to the 3GB of space that you get on wordpress.com (unless you pay for space upgrades).

    I just posted my first video on my wordpress.org site: http://www.kevinesmeier.info/chelsea61309/. I chose a lower quality for video file size, to see an example of higher quality video, see Matt Thomas’ blog (http://www.iammattthomas.com).

    This is still better than dealing with all that YouTube garbage and screening comments from somewhere else, etc. The fact that you get a “clean screen view” once you move the mouse off the video makes it very appealing. I just wish there was a better way to post the video on wordpress.org.

    If anyone has a better way of doing this, please share.

    I am almost embarrassed to ask this but….I can’t find the link to video press download! I am looking for the Upgrade tab in 2.8 and I can’t find it, what am I missing please. ( this is going to be so obvious when I find it!)

    Thanks for the explanation Kevin.

    I’m with harpoon…another newbie that can’t seem to find the upgrade button to get videopress. There’s an upgrade button under tools, but that’s not the one. I’m fresh with version 2.8

    You get the upgrade for video from WordPress.com, under “Upgrades” on the dashboard.

    Remember, anything you do with the video itself is on WordPress.com – you’re only writing your post and embedding your video with WordPress.org.

    Hope that helps.

    Yes, thank you! At least you got me in the right direction. However, because I setup my wordpress with my hosting provider, I cannot register it with wordpress.com. wordpress.com requires you to have the “/wordpress” attached to your domain name and I don’t have it that way, it’s just my domain name. If you could help me further, I’d really appreciate it kevnetik
    Thanks~!

    Had the same problem, but tried a different approach. Manually change the “wpvideo” to “videopress” (minus the quotes of course) and I got it to work.

    Like kevnetik said, you have to choose “embed” or it will not show up on self-hosted web sites.

    As with the posts above I have a hosted site using WP.template. Do I have to create another site on wp.COM just to have access to the video player?

    you have to have a wordpress.com login and you have to choose to setup a blog but you don’t actually have to post anything there. However I had the same problem on my self hosted. kevnetik’s work around worked for me. Thanks Kev!
    Here is a video link that explains the process minus the work around above. http://freewptraining.com/how-to-add-videos-to-wordpress-and-host-them-with-videopress

    I’ve been reading these forums – out of sheer frustration at trying to post video on my wordpress.org website – and SO I did finally give in and purchase the Video Press upgrade. While it “works,” to my shock, it actually features an “Embed” option in the upper left corner of the video – allowing ANYONE to copy MY WORK (this is a business website btw, I’m a professional videographer) and then repost it in their own sites??!! Yet, as kevnetik said above, if you don’t leave the “embed” option checked, the screen will go black on your site? Does anyone know how to play your videos on your site using Video Press (from WP.com over to WP.org) WITHOUT allowing the public access to copy and embed my work?

    Thanks, Tim

    I just purchased the videopress upgrade. and I get an error when I click the Videopresds buttonin a post. it seems to be trying to load a linked blog in the window

    I have a few blogs linked in my wordpress.com account it seems to be trying to load one of those instead.

    djvibe -I have the exact same issue. Any resolution?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Anybody get Videopress working?’ is closed to new replies.