Support » Plugin: DB Cache Reloaded Fix » Any way to use it on WP 4?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi dear, this plugin I think is abandoned…

    Same error in WP 4.7.3.

    Delete & (ampersand) before “new” and check if it works:
    $this->dbcr_cache = new pcache();

    Make the same corrections in the following files:
    db-module.php
    db-module-wrapper.php

    superkaratemonkeydeathcar

    (@superkaratemonkeydeathcar)

    Great stuff @errorsys!

    I also checked it with a PHP7 Compatibility Plugin and this was the output:

    FILE: /home/mysite/public_html/wp-content/plugins/db-cache-reloaded-fix/db-functions.php
    ———————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————
    54 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————

    FILE: /home/mysite/public_html/wp-content/plugins/db-cache-reloaded-fix/db-module.php
    —————————————————————————————————————-
    FOUND 9 ERRORS AFFECTING 9 LINES
    —————————————————————————————————————-
    214 | ERROR | Assigning the return value of new by reference is deprecated in PHP 5.3 and forbidden in PHP 7.0
    411 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    421 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    427 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    430 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    440 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    441 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    445 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    450 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    —————————————————————————————————————-

    FILE: /home/mysite/public_html/wp-content/plugins/db-cache-reloaded-fix/db-cache-reloaded.php
    —————————————————————————————————————–
    FOUND 1 ERROR AND 1 WARNING AFFECTING 2 LINES
    —————————————————————————————————————–
    73 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    91 | ERROR | Assigning the return value of new by reference is deprecated in PHP 5.3 and forbidden in PHP 7.0
    —————————————————————————————————————–

    FILE: /home/mysite/public_html/wp-content/plugins/db-cache-reloaded-fix/db-module-wrapper.php
    —————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————————————————-
    105 | ERROR | Assigning the return value of new by reference is deprecated in PHP 5.3 and forbidden in PHP 7.0
    —————————————————————————————————————-

    I wonder that if for people who know PHP a little better than I do, these could all be easy fixes?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.