WordPress.org

Forums

Toolbox
Any version of Toolbox compatible with WP 3.0.1? (8 posts)

  1. nimblematt
    Member
    Posted 3 years ago #

    Hey there,

    I've been developing a theme for a site hosted on a university network. I've been using Toolbox as a starter theme, and have developed it without issue locally. This evening I went to push it onto the development server I have access to and ran into some issues.

    The university has some fairly strong restrictions on the platforms it will run, and upgrades to those platforms are not swift, by any measure. Currently they are running WP 3.0.1, which to my surprise, will not run a toolbox based theme.

    Is there a version of toolbox that is compatible with 3.0.1?

    Thanks!

    http://wordpress.org/extend/themes/toolbox/

  2. It's probably asking for trouble but if you are SVN savvy, try one of the earlier releases.

    http://themes.svn.wordpress.org/toolbox/

  3. nimblematt
    Member
    Posted 3 years ago #

    Yeah, I did a little poking around in svn to see what was there. I wasn't able to find any references to version compatibility, though. I may just not be looking in the right place. Is there a spot where that information is normally located?

  4. Normally the readme.txt may have something there but that's not the case here... Your best bet would be to try the earlier releases one at a time and see if any of them work with 3.0.1.

  5. nimblematt
    Member
    Posted 3 years ago #

    Thanks for the help, Jan. I gave 1.0 a shot and it worked just fine. I figured I'd post here in case anyone else ran into the same issue. I'll be sure to follow up if I run into further problems.

    I must say I am surprised that there is no version compatibility information on the download page. I can't help but think that I'm not the only one running into this issue.

    Cheers!

  6. Lance Willett
    Themer
    Posted 3 years ago #

    @nimblematt Could you help us troubleshoot things by giving us information on what didn't work? Any PHP errors? Did you have trouble loading a specific post or page? What browser and OS?

  7. Lance Willett
    Themer
    Posted 3 years ago #

    Looks like Toolbox requires at least WordPress 3.1 — and the latest stable version, 3.2, would be the best choice.

    The theme uses quite a bit of new WP functionality, including get_post_format() — added in WP 3.1 — and is_multi_author() which was added in 3.2.

  8. Lance Willett
    Themer
    Posted 3 years ago #

    Correction: Toolbox requires 3.2 or higher.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags