Forms: 3rd-Party Integration
Any tips for Velocify? (6 posts)

  1. Jon Brown
    Posted 1 year ago #

    My debug email reports success and my fields being sent,

    *** Post (to Service) ***
       [timeout] => 10
       [body] => Array
               [First Name] => Jon
               [Last Name] => Brown

    And the response body says success, but I get empty records at Velocify.

    I'm thinking my remote field names must be wrong and not matching up, although they should. Wondering if I'm missing something else entirely.

    Even a "should work" would be helpful so I know I'm not banging my head against a wall.


  2. zaus
    Plugin Author

    Posted 1 year ago #

    Can you provide the full debug email (scrubbed of anything that should be 'secret')? You're just showing the submission, not the full response.

    I did some work integrating Velocify not too long ago, and the results seemed to not be there until I sorted the submissions by date, and then I was able to see them. Velocify also needed a unique reference id, which you can create with ##UID## using the Dynamic Fields addon.

  3. Jon Brown
    Posted 1 year ago #

    Thanks @Zaus. I posted a gist of it.

    I saw the Dynamic Fields addon but wasn't sure if it was actually still necessary. FWIW, I was talking with my coworker Josh (he started setting it up and may chime in here) and the issue may be that we never told Velocify to expect the data. We assumed their API was active, but I think they may actually need to enable it and identify which fields it should expect.

    Also note, the debug shows us trying to post to several version of "First Name", that was me shooting in the dark, the correct field names are the first two.

  4. zaus
    Plugin Author

    Posted 1 year ago #

    Not sure what to tell you -- the response coming back from Velocify says success with a leadid of 54931.

    Was the issue as you thought? Did you get it to work?

  5. Jon Brown
    Posted 1 year ago #

    Thanks Zaus. Still not working unfortunately. We had Velocify setup the fields and API on their end. The response code come back 200 and the a record is created, it's just the record is empty.

    It's odd though. Now we have a dozen fields (debug shows them in form, but not in "Post (to Service)" section. Even the two that do show don't get recorded. Velocify just get an empty record.

    I tried add the Dynamic Fields add-on and post a UUID along with the data at which point I got this debug response

    When I tried it before adding the UUID the response was essentially the same just not UUID being sent.

    Contacting Velocify again and hoping they have an idea...

  6. zaus
    Plugin Author

    Posted 1 year ago #

    The fields aren't being posted to Velocify because your mapping is wrong -- GF is a little weird, but the field keys from the *** Post (Form) *** section should match the src values in the *** Service *** section mapping array (what you enter in the admin mapping config). It's possible Velocify is rejecting the lead because there's basically no lead data -- I'm guessing it needs at least an email to create a record.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Forms: 3rd-Party Integration
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.