WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Another upload picture problem – Cant upload anything [critical]

[Resolved] Another upload picture problem – Cant upload anything [critical]

  • Upgraded today.
    Apache 1.3.41 (Unix)

    If i try to upload an image (gurrenost.jpg for example) I get:

    gurrenost.jpg

    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1042

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1033

    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1042

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1033

    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/s03d7073:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/s03d7073/public_html/blog/wp-includes/functions.php on line 1042

    I have not seen any other thread related. Other are about multiple upload problems or with a specific browser, but not something critical like this.

    Tried with Opera (latest build), IE7, Firefox 3 beta 4, Firefox 2 …

    I have tried to delete htaccess but it keeps failing …

    Any idea?

Viewing 2 replies - 1 through 2 (of 2 total)
  • smoothplanet
    Member

    @smoothplanet

    You may want to check your settings, the value in “Settings” -> “Miscellanous” -> “Upload path” should not start by a slash “/”.
    Make sure you have something like:
    wp-content/uploads
    and not
    /wp-content/uploads

    That fixed the problem for me… 🙂

    Thanks! It works.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Another upload picture problem – Cant upload anything [critical]’ is closed to new replies.