Support » Fixing WordPress » Another 'Save Draft' Button Goes Kaput

  • I’ve got a problem — like several others here — that popped up after upgrading to version 3.0 of WordPress. My ‘Save Darft’ and ‘Preview’ buttons no longer function properly.
    If I create a new post and try to preview it or save a draft, neither work. The preview brings up my site, but the posting is empty as though I didn’t type anything. When I save a draft it acts like it saves, but when I return to the main posts list it’s not there. It didn’t get saved.
    If I just publish a posting without doing either it -usually- posts. Sometimes the wheel spins for awhile and times out. If it does post I can -usually- go back in and downgrade it to a draft, but any changes I make after that don’t save out unless I publish again.
    However, when I use ‘Quick Press’ on the main Dashboard page both the draft save and preview buttons work perfectly.
    Here’s what I’ve done to troubleshoot:
    1. I deactivated all plugins.
    2. I reset the plugins folder.
    3. I switched to the default theme (with plugins deactivated).
    4. I re-uploaded the ‘wp-includes’ and ‘wp-admin’ folders with a fresh download of 3.0.
    5. I tried doing test posts after all of the above in both IE8 and Safari with no luck.
    None of this has made a difference. So my brain storm has fizzled out. I don’t think it’s a, dare I say it, BUG in 3.0 because it doesn’t seem to be affecting that many users.
    Everything worked flawlessly on 2.9.2 In fact, a second site I have is still on that version. I’m not upgrading it in fear of the same thing happening.
    I’m wondering if it could be an issue with my web hosting? I use Yahoo. Could it be a permission thing? Maybe memory? I’m not really knowledgable when it comes to servers and what not. I may call them after feedback here.
    Also, this may be related, right after the 3.0 upgrade the ‘Akismet’ plugin starting acting up. It was causing all sorts of glitches and problems with my WordPress Interface such as timeouts and other buttons not responding. It also blocked the ‘WordPress Development Blog’ and ‘Other WordPress News’ and displayed errors in those boxes. Anyone else experience this? This went on for about 3 days after updating to 3.0. Finally, I deactivated it and everything is back to normal except for the ‘Save Draft’ and ‘Preview’ buttons. I’d like to turn Akismet back on, but I don’t know why it won’t work properly since updating to 3.0.
    Suggestions? Thoughts?

Viewing 4 replies - 1 through 4 (of 4 total)
  • go to edit post screen
    top tab – set to show 2 columns

    Thanks Samuel B, unfortunately that didn’t work.

    I was already on 2-column view. But I went ahead and tried 1-column mode… no luck. Then switched back to 2 and still nothing. The buttons are there. They just don’t work.


    Exact same issue, I’m using 3.0.
    Have you found a solution yet?
    I have a WP/SEO firm under hire that helps me design and build websites/blogs. After searching forums and burning a lot of time this past weekend I have sent the problem to them. They have WP experts on staff that will be able to figure this out. It will cost me a few bucks but when I find out the solution I will post here. Sometimes they just fix it and will not reveal what they did in specific details. They like my monthly retainer!


    Thanks for the reply. I’ve since upgraded to 3.0.1 and then 3.0.2 and those buttons seem to behave ‘slightly’ better. I still can’t save drafts from the Post page. I have to save it as a Draft in the Quick Press window on the main Dashboard and then head to the Post section where I can save it or publish it.

    The latest problem I have is not being able to publish new pages. When I hit the Publish Button the little circle spins for a minute or more. It then throws up a server connection error (timed out). Then the page appears on my site. But when I go to it… the content is missing. I get the title and right under it this line “|” then under that the “Edit” link.

    I’m certain this is the same glitch causing the other problems I originally posted. I’d love to hear your solution if you get one from your company.

    Thanks again!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Another 'Save Draft' Button Goes Kaput’ is closed to new replies.