Support » Fixing WordPress » ANOTHER media upload/image issue..

  • Resolved sleijon


    I’ve read the “sticky” post on known issues with the media uploader, but it seems I have yet another issue.
    I made a short video explaining what happens:

    I also took a peek in the folder /wp-content and found that there was no /wp-content/uploads folder, so I created one.
    I thought the folder would be created by itself by me uploading an image, but I crated the folder just in case. Tried uploading from “media uploader” and still nothing.
    Then I put an image in the /wp-content/uploads folder through my ftp, I could then see the image in “media library” and that seems to work fine.
    BUT.. I really don’t want to have to go through all that every time I make a post.
    There has to be a solution..

    Thankful for any suggestions / solutions..

Viewing 7 replies - 1 through 7 (of 7 total)
  • ^^ bump ^^

    anyone? ideas?

    Moderator kmessinger


    You should have folders uploads then 2009 then 01.

    They should have permissions of 755.

    If you have problems with the Flash uploader, try the Browser uploader.

    Thank you for taking the time to answer.

    I tried creating those folders; wp-content/uploads/2009/01
    and set them all to permissions of 755, but the images are not showing up on the server at all. (neither with the flash or the browser uploader)
    The descriptions show up in “media library”, but the image itself never make it to the server.
    Are there possibly any other settings that I should look at to fix this?

    I got almost the same exact problem. Whenever I try to upload a picture I get the message that it failed and that I should make sure that the parent folder is writable (755) I checked in my ftp program and it is the case, so now I’m not really sure what to do.

    Moderator kmessinger


    You might want to read

    I would turn off all plugins and see if it works. Also try from a different browser and try to upload other files like maybe an audio.

    Acts like a permissions problem though.


    It was a series of settings in my controlpanel.
    I got it working after a little digging with your help of what to look for.

    For others with similar problems, here’s the main issue that I think did the trick.
    I had already set my wp-contents folder to permission 777 (read, write, execute).
    Now, I found that the files actually did show up, I just needed to refresh my ftp software to see them.
    They ended up in wp-contents, not in wp-contents/uploads.
    So, I checked in my controlpanel under “settings” and then “other”, and I think what confused me was that the default setting for “save uploaded files in this folder” (in the text field) was already filled in as “wp-content”, but right next to the same text field was the text “pre-selected folder is wp-content/uploads”, so I mistook the later text as being the default setting.
    All I had to do is to write in “/uploads” after “wp-content” in the text filed and hit save..

    @kmessinger, thanks for your input, it was very helpful.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘ANOTHER media upload/image issue..’ is closed to new replies.