WordPress.org

Support

Support » Multisite » [Resolved] another "images broken in multisite" with a wp_debug twist

[Resolved] another "images broken in multisite" with a wp_debug twist

Viewing 8 replies - 1 through 8 (of 8 total)
  • I checked with DreamHost; AllowOverride is none

    Mika Epstein

    @ipstenu-dh

    DreamHost Rep

    That would be why (though it surprises me…)

    You can edit it if you have a VPS: http://wiki.dreamhost.com/VPS#httpd.conf

    They just migrated a datacenter and a couple of quirks have popped up. This may be one!

    Was this working before we moved you? If so, ask support to change it back for you 🙂

    It was working for a year or two! I’ve opened a support ticket.

    The strangest thing is that on Tuesday, around 10 users disappeared from wp_users. Is there any way that could be related?

    The last DH rep I talked to insisted that I could set AllowOverride in .htaccess

    adding
    <Directory />
    AllowOverride Options
    </Directory>

    gives me 500 internal server error. Is my syntax incorrect? Is this even going to work?

    Mika Epstein

    @ipstenu-dh

    DreamHost Rep

    Maybe… Try this?

    <Directory /home/myname/mydomain.com>
    AllowOverride Options All
    </Directory>

    The strangest thing is that on Tuesday, around 10 users disappeared from wp_users. Is there any way that could be related?

    It’s possible, but they sound like coincidence. Kind of like the ‘everything that can go wrong, will at the same time…’

    That didn’t work.

    BUT I GOT IT!
    I thought…
    why might this URL be not working?
    http://samadhi.gabeherbert.com/wp-includes/ms-files.php?file=2012/11/rainbowcake-125×125.jpg

    then noticed the .htaccess file that existed in wp-include:

    <Files *.php>
    deny from all
    </Files>
    <Files wp-tinymce.php>
    allow from all
    </Files>

    *facepalm*

    I’m pretty sure that came from Sucuri’s “one-click hardening”. They seem smarter than that. What’s going on here?

    Switching hats, since yu don’t need my DH self for this one 😉

    <Files *.php>
    deny from all
    </Files>

    That makes no sense at all, and I doubt sucuri would do that since it says “No one can get to any PHP files! HAHHAHHAHHAHHAH!’

    Confirmed that this came from the sucuri plugin!

    I’ve informed their support :p

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] another "images broken in multisite" with a wp_debug twist’ is closed to new replies.
Skip to toolbar