Support » Fixing WordPress » Another .htaccess issue w/ permalinks

  • Just setup wordpress on my site.

    I have the main wordpress installed to /
    but the index file in / (as I dont want people going to the /blog site, want them to find my site via my main domain)

    First off, when I try to setup permalinks, I started with NOT having a .htaccess file.
    WhenI select any of the permalink options (ie. custom structure) it doesn’t work.
    I have “” If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.”” on the bottom of the screen.

    So I then made a .htaccess file on my mac, blank, and uploaded it to my directory (where the WP files are). Same problem, message.
    If I add what it tells me to add, same issue. Am I missing something here?

    Again, I initially installed WP to /blog directory. But then I read on here how to move it so it would be brought up when you load my domain, which it does.

    Help please.

Viewing 1 replies (of 1 total)
  • Moderator Mark Ratledge


    Forum Moderator

    Delete the .htaccess file you uploaded and start over. Create the .htaccess file on the server with an FTP client, not on your Mac. The file needs to be the correct file type with correct line endings, and if you create it on your Mac, chances are it won’t be and won’t have the correct permissions, either, for CentOS, your web host.

    If that doesn’t work, ask your web host; they may have some unusual permission settings.

Viewing 1 replies (of 1 total)
  • The topic ‘Another .htaccess issue w/ permalinks’ is closed to new replies.