Support » Networking WordPress » Another Domain Mapping Issue

  • Resolved kprensac


    I have been running into problems with multisite domain mapping that I have not been able to solve. I have gone several rounds with hostgator support without success. Here is the scenario:

    I have a hostgator account for the URL It is a new install of wordpress 3.0 configured to have WP multisite capabilies. I then created a new a subdirectory site at Everything seemed to be working fine.

    I then tried to map the domain “” to the subdirectory site “” using the “wordpress-mu-domain-mapping” plug-in. I have been using the method described in

    I installed the domain mapping plugin as suggested and everything seemed to set up fine. Since “subsitecom” was purchased through godaddy and I went to the godaddy contol panels and changed the DNS “A” record of to point to my hostgator ip address of XXX.134.XXX.743. I then went to my hostgator cpanel for and created as an addon domain (without any redirect rules).

    I then went into my wordpress admin for and set up the additional domain of of “” to be mapped to that subdirectory site. That subdirectory site now has two domains listed: 1) and 2)

    When is checked as the primary domain everything works as expected. The site loads perfectly, the backend is fully functional, and when you navigate in the browser to you get automatically redirected to (with showing as the final URL).

    However, all hell brakes lose when you go to domain mapping admin for and try to make the change to as the primary domain. Specifically, I mark the radio button for and hit the “set primary domain” button and then I get a white screen with the following error message:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, and inform them of the time the error occurred

    Notice the syntax of the address in the message “”. It appears to be looking for a subdomain “subsite.” I don’t know why this is happening.

    After this happens if you navigate to EITHER or you get a firefox message that states:

    The page isn’t redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    Does anyone know what is going on here and/or how to fix it. Any assistance would be greatly appreciated

Viewing 4 replies - 1 through 4 (of 4 total)
  • Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Go to Super Admin -> Sites and find the site you want. Edit it. Change the folder links to the full domain & saved. Should be fixed.

    Hi Andrea,

    Thank you very much for the response. Unfortunately, I’m not quite sure what you mean by “Change the folder links to the full domain.” I’ve gone to Super Admin -> Sites and found the site I wanted (in the case of my example it is listed as “/subsite/”). I then went to the edit page for that site. There are 4 fields that I see that I think would be relevant to your suggestion.

    In the top section “Site Info (wp_blogs)”, there are 2 relevant fields:

    1) Domain (currently listed as “”); and
    2) Path (currently listed as “/subsite/”) with a checkbox underneath that says “Update siteurl and home as well.” – the checkbox is active

    In the next section “Site Options (wp_3_options)”, there are 2 other relevant fields:

    1) Siteurl (currently listed as “”); and
    2) Home (also currently listed as “”)

    I’m assuming that the “Domain” and “Path” stay constant but perhaps you can change the “Siteurl” and /or “Home” to the mapped domain of Am I even close to being on the right track? If so, I’ve tried several different combinations but can’t get it to work.

    I’m sorry for being thickheaded but I just can’t figure out what to do when you say “Change the folder links to the full domain.” Could you explain with a little more specificity and detail.

    I appreciate the information and effort.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    On that page, everywhere it says change it to your mapped domain.

    OK Andrea — progress. That’s the info I needed and I changed those settings. There was one last piece of the puzzle. At hostgater had to be changed from an addon domain to a parked domain. Once it was a parked domain, everything worked as expected.

    However, I seem to have lost functionality on some of the javascript controls on the gallery pages (it’s a photo gallery site using simpleviewer flash galleries). That’s a separate issue that I need to debug myself (unless you happen to have some idea offhand). At least the domain mapping issue is now solved. Thanks again for all your input.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Another Domain Mapping Issue’ is closed to new replies.