Support » Plugin: Twitter Widget Pro » Another authorization issue

  • Another variation on the Twitter account authorization issue.

    In addition to my live website, I have a version I run on a local server to allow me to try things out, tweak CSS etc. before I make changes to my live site. I successfully installed Twitter Widget Pro on my local server, authorized my Twitter account, and it all worked beautifully!

    So I then decided to add it to my live site. Unfortunately I (foolishly, it seems) tried to use the same Application with the same Consumer Key and Secret as for my local site. That didn’t work, so I tried making a new Application on the Twitter Dev site. Even using the new details it still didn’t let me authorize my Twitter account.

    Interestingly, after I click the Authorize New Account button, I’m taken to the annoying page that says “Whoa there! The request token for this page is invalid.” However, when I go to the “Apps” tab of my Twitter account’s settings, it lists the App there (and it is the new one I created for my live site, as I gave it a different name). So it seems Twitter considers the App to be authorized for my account but the plugin doesn’t.

    Any suggestions?

    One thing I’d like to try is to completely uninstall the plugin and start again. However, even deleting the files doesn’t clear the settings and keys from WordPress as they are stored in the database. I’m kicking myself for not backing up before installing the plugin. I have tried manually deleting rows from wp-options (all the ones with option_name starting ‘twp’ or ‘_twp’. Is there anything else I should delete?

Viewing 1 replies (of 1 total)
  • OK, so I have managed to get my “real” site working. However, I couldn’t do it “properly”, and I feel this may indicate an issue with the way shared servers used by some hosting companies are set up. This may explain why so many users are reporting problems in this forum.

    First I had to create a new Twitter application and Authorize my account for use on my local server, as I did before. This worked correctly just as it did last time.

    As my public server still wouldn’t Authorize my Twitter account, I viewed the database tables for my local server and copied the ‘twp’ and ‘twp-authed-users’ rows to my live server. Then all I did was refresh the settings page and it showed my Twitter account as authorized.

    I realise this isn’t much help to most people unless they have an alternate server and the time to install WordPress on it. However, I feel it shows the plugin works fine except for the Authorize stage which has problems on particular server setups. If the author could suggest the best way to debug the communication between the WordPress server and Twiter I’d be happy to help, as I understand it’s difficult for him to fix this when it works correctly for him.

    For the moment, one difference between the two servers that springs to mind is that the “live” server runs PHP via fastcgi, while my local server runs it as an Apache module. Otherwise they are set up quite similarly.

Viewing 1 replies (of 1 total)
  • The topic ‘Another authorization issue’ is closed to new replies.