Support » How-To and Troubleshooting » [Resolved] Another "An error occurred in the upload…" Issue

[Resolved] Another "An error occurred in the upload…" Issue

  • Hi Guys,
    I’ve been reading through the forums trying to resolve what appears to be a common problem with photo uploads.

    I’m running the latest version, 3.8, and using Arras theme.

    When I (Administrator) or others (Editor or Author) try to upload photos we’re seeing, “An error occurred in the upload. Please try again later.”

    If one closes the window, saves a draft, then returns to the media insertion, the photo appears seems to be successfully uploaded and is usable.

    I’ve tried disabling all plugins, switching to a simple theme, like twentytwelve, but it still gave same errors on upload.

    This issue has been around for a long time, and sometimes disappears. At one point I thought it was a folder permissions issue, and it seemed to get resolved by making sure they were set to the correct user. cPanel seems to sometimes adjust these things. However, now the permissions seem correct and I’m totally stuck.

    Any suggestions?

Viewing 15 replies - 1 through 15 (of 17 total)
  • esmi


    Forum Moderator

    Try checking your site’s error logs for a more specific error message. Your hosts should be able to help you accessing your site’s error logs.

    Hi Esmi, Thank you, but there are no errors in the error log relating to wordpress.
    Any other ideas?



    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder and wp-config.php & root .htaccess files – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    Sounds like WordPress rushed this latest update out and there’s too many problems with it.



    Forum Moderator

    @kaotik – this is not your thread – if you need help, please start your own.

    Hi esmi, I just spent a couple hours doing all of what you suggested. It’s still not working.
    Again, maybe these clues can help you suggest a fix… when I go to upload, it seems to get to 98%, then drops to about 50%, then again 98%, repeated this 1-3 times total. After, if I return to compose and save a draft, when I open the media, the photos are there, often multiple times.
    Any ideas?



    Forum Moderator

    Site url?



    Forum Moderator

    You are not using the default theme and you have multiple active plugins.

    Hi Esmi, I just put everything back after resetting from no plugins and twentytwelve theme. What do you suggest?
    I can revert again if you can debug by looking at it in that state.
    Let me know. Thanks.

    Hi Esmi, I’d really appreciate your help on this. Do you need me to go back to no plugins and twentytwelve theme in order to proceed?

    This is resolved now. I believe the issue is tied to directory ownership caused by cpanel updates.

    Hi hcvg!
    Can you elaborate on the directory ownership problem? I would love to fix this on my site – it’s making me CRAZY!

    Hi Joe,
    It’s running on a dedicated server using apache. Instead of running as “User/Group” it was set to “nobody / nobody”. Once we fixed that, wordpress then had the correct permissions.
    Hope that helps. Best.

    I spent half day fighting with this problem and soloved it, Hope this may help you

    in “FUNCTIONS.PHP” file
    Make sure you don’t have any lines with comments in HTML mark up (Example <!– I am a HTML code comment –> )
    Make sure you open and close the PHP tags ONLY ONCE!!! in the file.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Another "An error occurred in the upload…" Issue’ is closed to new replies.