Support » Fixing WordPress » Another 404 not found issue with comments

  • and comments only. Today, after several days of “clean” working, with Quentin theme and these plugins: weather hack from Jeremiah et al; Feedread from David Chait; and SpamAssassin from Michael Hampton – I have now got 404 not found pages when comments are attempted. Earlier comments are viewable/editable. Comments are not being held for moderation. The fields for name and email are not showing. Logging out/back in does not correct the problem.

    Disabling all of the plugins did not correct this issue. Overwriting comments.php with the default version did not correct this issue. I’ve tried various other fixes listed herein (using a search), none of which worked, and I can’t remember now what all of them were.

    I want posters to have to register; and have to enter name and email; and unless they’ve already been approved for a post or comment, to have to wait for moderation – so all of those boxes are checked.

    Anyone have ANY new ideas?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hmm. Guess not, huh?

    I’ve redone everything. Redownloaded the package, reuploaded the package to my host server in a “bare” clean, vanilla folder. Re-followed podz’s “how to” exactly, and everything runs fine, posting works fine. BEFORE I added in any plugins, themes etc. this time, I tried it out – and I’m still getting a 404 not found error when I attempt to add a comment. So it’s not the few usability tweaks I did.

    The really odd thing is that it worked fine for almost a week before haring off onto this 404 tangent.

    I have this problem too (WP 1.5) – I’m assuming you have permalinks enabled right? When I disable permalinks, I can comment fine, when they’re enabled, error 404.

    No plugins installed.

    My permalink structure is:

    and will give:


    No. I don’t have permalinks enabled. I never got far enough with it to enable them.

    Damn 🙁

    Yeah – sure would be nice if a dev or someone could come up with something logical as to why this is happening….

    Okay. A conversation with an apache guru a few minutes ago on another forum led me to the base problem in my particular case (YMMV). It was totally a case of my forgetting to change a line in the .htaccess file after I installed wp-spamassassin. Unistalling the plugin didn’t help, because that didn’t unistall the .htaccess file.

    All fixed now. Don’t know if this will help anyone else, but if you HAVE done anything with the .htaccess file, look over your changes!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Another 404 not found issue with comments’ is closed to new replies.