Support » Plugin: Yoast SEO » Another 14.9 update crash

  • Resolved hommealone

    (@hommealone)


    After updating to your version 14.9, and then updating core to 5.5.1, the website crashed. Not right away mind you! I checked the site right after the updates and it was running fine, front end and back end.

    Three hours later, I received an email from my website that there was a critical error involving your plugin. Neither the front end or back end were accessible.

    I renamed your plugin directory via FTP (to wordpress-seoHOLD) to disable it, and was then able to access the admin area again, and the front end loaded again as well.

    The email said:

    Your Site is Experiencing a Technical Issue

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with one of your plugins, Yoast SEO.

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.5.1
    Current theme: bright-side (version 1.0.0)
    Current plugin: Yoast SEO (version 14.9)
    PHP version 7.3.16

    The email also shows this error message:

    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 8 of the file /{path to root}/wp-content/plugins/wordpress-seo/src/helpers/current-page-helper.php. Error message: Namespace declaration statement has to be the very first statement or after any declare call in the script

    I can’t easily disable all of the other plugins to look for a conflict; there is no staging site.

    Hopefully this error message will be enough to help you?

    Please advise. Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • (I have rolled back to version 14.8.1 for now.)

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @hommealone,

    Thank you for reaching out!

    We understand that you are having issues a few hours later than installing the update. Thank you for your extensive explanation. Let’s find out what’s happening.

    First, the file and error referred in the E_COMPILE_ERROR, mentions issues about the namespace missing. We’ve checked the plugin and the file starts with namespace Yoast\WP\SEO\Helpers;. The namespace is the first line.

    We would recommend trying the following:

    1) Deactivate and delete the Yoast SEO plugin and reinstall the latest version. You are not losing any configuration or previously entered data such as keyphrases while doing so, they are stored in the database.
    When you did this, please check if the issue reappears after a while. If it does, please continue with step 2.

    2) We would like to know if you are running any serverside or site-side caching implementations? If so, please temporarily deactivate it and see if that resolves the issue.

    I’ll run that test little later today, thanks.

    Would you consider Autoptimize a caching method that I should disable? It is the only caching related thing we are using right now. (And we don’t have a CDN to cache the Autoptimize files.)

    Well, Autoptimize does not do page caching, but if you want to see a page without Autoptimize’s CSS/ JS/ HTML optimizatoins you can do so by adding ?ao_noptimize=1 to the URL.

    hope this helps debugging,
    frank

    I deleted the old (renamed) plugin directory. I updated the 14.8.1 version that I’d reverted to. Now running version 14.9 without any problems.

    BTW, I do believe that Autoptimize caches the minified, concatenated files. I cleared the Autoptimize cache right before and after updating.

    But it might just have been a one-off corrupted file or something during download or similar that caused the first problem. Anyway, it’s fine now!

    Thanks for your help.

    Sam

    (@xumbrella)

    There is definitely something funny going on with Yoast and Autoptimize as I just updated to Yoast 4.9 and got the critical error screen. After reading this post I manually disabled the plugin and then the site came back. I then cleared the Autoptimize cache and reactivated the Yoast plugin and everything works.

    Hope that helps some people.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.